Add IFF_DONT_BRIDGE definition to compat
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 20 Nov 2009 22:01:51 +0000 (23:01 +0100)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 21 Nov 2009 02:17:46 +0000 (18:17 -0800)
The IFF_DONT_BRIDGE flag will not be interpreted by an old kernel, but
it does not hurt the kernel if it is set but not read by the non
wireless network code.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
compat/compat-2.6.33.c [new file with mode: 0644]
compat/compat-2.6.33.h [new file with mode: 0644]
compat/compat.h
compat/patches/98-add-compat-wireless.patch

diff --git a/compat/compat-2.6.33.c b/compat/compat-2.6.33.c
new file mode 100644 (file)
index 0000000..2fccadb
--- /dev/null
@@ -0,0 +1,16 @@
+/*
+ * Copyright 2007      Luis R. Rodriguez <mcgrof@winlab.rutgers.edu>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
+ * Compatibility file for Linux wireless for kernels 2.6.33.
+ */
+
+#include <net/compat.h>
+
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
+
+#endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33)) */
+
diff --git a/compat/compat-2.6.33.h b/compat/compat-2.6.33.h
new file mode 100644 (file)
index 0000000..528627e
--- /dev/null
@@ -0,0 +1,15 @@
+#ifndef LINUX_26_33_COMPAT_H
+#define LINUX_26_33_COMPAT_H
+
+#include <linux/autoconf.h>
+#include <linux/version.h>
+#include <linux/compat_autoconf.h>
+
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
+
+#define IFF_DONT_BRIDGE 0x800          /* disallow bridging this ether dev */
+/* source: include/linux/if.h */
+
+#endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33)) */
+
+#endif /* LINUX_26_33_COMPAT_H */
index 05612b2f41261d83d3143b8a8baf41d53c767b0c..76e998d320bf7ac5f4a41864035d229b096f5bdd 100644 (file)
@@ -21,5 +21,6 @@
 #include <net/compat-2.6.30.h>
 #include <net/compat-2.6.31.h>
 #include <net/compat-2.6.32.h>
+#include <net/compat-2.6.33.h>
 
 #endif /* LINUX_26_COMPAT_H */
index e78c63f1233970f0c0c9be9a9f3632652a3220cd..0bbf85b4fa1dc91afd7af640048223516e828846 100644 (file)
@@ -20,7 +20,7 @@ added compat.h also for ssb, I forget.
 
 --- a/net/wireless/Makefile    2009-08-07 12:27:50.836497001 -0700
 +++ b/net/wireless/Makefile    2009-08-07 12:27:51.952497240 -0700
-@@ -15,3 +15,16 @@
+@@ -15,3 +15,17 @@
  cfg80211-$(CONFIG_CFG80211_WEXT) += wext-compat.o wext-sme.o
  
  ccflags-y += -D__CHECK_ENDIAN__
@@ -36,6 +36,7 @@ added compat.h also for ssb, I forget.
 +cfg80211-$(CONFIG_COMPAT_WIRELESS_30) += compat-2.6.30.o
 +cfg80211-$(CONFIG_COMPAT_WIRELESS_31) += compat-2.6.31.o
 +cfg80211-$(CONFIG_COMPAT_WIRELESS_32) += compat-2.6.32.o
++cfg80211-$(CONFIG_COMPAT_WIRELESS_33) += compat-2.6.33.o
 +
 --- a/include/net/cfg80211.h
 +++ b/include/net/cfg80211.h