bpf-headers: update to version 6.6
authorFelix Fietkau <nbd@nbd.name>
Fri, 20 Sep 2024 21:17:28 +0000 (23:17 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 20 Sep 2024 21:17:43 +0000 (23:17 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/bpf-headers/Makefile
package/kernel/bpf-headers/patches/100-support_hz_300.patch
package/kernel/bpf-headers/patches/101-linux-netlink-drop-NL_SET_ERR_MSG-for-kernel-modules.patch [deleted file]
package/kernel/bpf-headers/patches/102-net-flow_offload-use-NL_SET_ERR_MSG-instead-of-NL_SE.patch

index e75da738e6862ee7c95654c6389f6e829025a264..a644f47ab726f8f48c013899bbb482ccaa4f8cb9 100644 (file)
@@ -13,7 +13,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 
 PKG_NAME:=linux
-PKG_PATCHVER:=5.15
+PKG_PATCHVER:=6.6
 # Manually include kernel version and hash from kernel details file
 include $(INCLUDE_DIR)/kernel-$(PKG_PATCHVER)
 
index 9629958598e7a4efd7d1c471d7ea0f2078d6fdd3..f2fba44bce42ab658c430f8ca13746c982879a85 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2988,6 +2988,9 @@ choice
+@@ -2820,6 +2820,9 @@ choice
        config HZ_256
                bool "256 HZ" if SYS_SUPPORTS_256HZ || SYS_SUPPORTS_ARBIT_HZ
  
@@ -10,7 +10,7 @@
        config HZ_1000
                bool "1000 HZ" if SYS_SUPPORTS_1000HZ || SYS_SUPPORTS_ARBIT_HZ
  
-@@ -3039,6 +3042,7 @@ config HZ
+@@ -2871,6 +2874,7 @@ config HZ
        default 128 if HZ_128
        default 250 if HZ_250
        default 256 if HZ_256
diff --git a/package/kernel/bpf-headers/patches/101-linux-netlink-drop-NL_SET_ERR_MSG-for-kernel-modules.patch b/package/kernel/bpf-headers/patches/101-linux-netlink-drop-NL_SET_ERR_MSG-for-kernel-modules.patch
deleted file mode 100644 (file)
index 5771b32..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 7ed95633bff19950069c348b94c9c13164a57a2a Mon Sep 17 00:00:00 2001
-From: Christian Marangi <ansuelsmth@gmail.com>
-Date: Wed, 18 Jan 2023 20:20:39 +0100
-Subject: [PATCH] linux/netlink: drop NL_SET_ERR_MSG for kernel modules
-
-We don't need NL_SET_ERR_MSG_MOD for bpf modules and we can drop it to
-solve missing KBUILD_MODNAME define.
-
-Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
----
- include/linux/netlink.h | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/include/linux/netlink.h b/include/linux/netlink.h
-index 61b1c7f..93561fb 100644
---- a/include/linux/netlink.h
-+++ b/include/linux/netlink.h
-@@ -98,9 +98,6 @@ struct netlink_ext_ack {
-               __extack->_msg = __msg;                 \
- } while (0)
--#define NL_SET_ERR_MSG_MOD(extack, msg)                       \
--      NL_SET_ERR_MSG((extack), KBUILD_MODNAME ": " msg)
--
- #define NL_SET_BAD_ATTR_POLICY(extack, attr, pol) do {        \
-       if ((extack)) {                                 \
-               (extack)->bad_attr = (attr);            \
--- 
-2.38.1
-
index 4dec16874ef19c870f4885ff26a18b8d4e7c0f89..bcaadc95a01297d1c328ab7ec9b9af8feb1588ae 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  include/net/flow_offload.h | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)
 
-diff --git a/include/net/flow_offload.h b/include/net/flow_offload.h
-index 7a2b022..f17c485 100644
 --- a/include/net/flow_offload.h
 +++ b/include/net/flow_offload.h
-@@ -321,7 +321,7 @@ flow_action_mixed_hw_stats_check(const struct flow_action *action,
+@@ -376,7 +376,7 @@ flow_action_mixed_hw_stats_check(const s
  
        flow_action_for_each(i, action_entry, action) {
                if (i && action_entry->hw_stats != last_hw_stats) {
@@ -25,7 +23,7 @@ index 7a2b022..f17c485 100644
                        return false;
                }
                last_hw_stats = action_entry->hw_stats;
-@@ -356,11 +356,11 @@ __flow_action_hw_stats_check(const struct flow_action *action,
+@@ -411,11 +411,11 @@ __flow_action_hw_stats_check(const struc
  
        if (!check_allow_bit &&
            ~action_entry->hw_stats & FLOW_ACTION_HW_STATS_ANY) {
@@ -39,6 +37,3 @@ index 7a2b022..f17c485 100644
                return false;
        }
        return true;
--- 
-2.38.1
-