projects
/
openwrt
/
staging
/
981213.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f919848
)
kernel: modules: block: adapt for kernel 6.6
author
Weijie Gao
<hackpascal@gmail.com>
Sat, 6 Jan 2024 08:12:06 +0000
(16:12 +0800)
committer
Robert Marko
<robimarko@gmail.com>
Mon, 11 Mar 2024 19:17:26 +0000
(20:17 +0100)
Adapt block kmods for building under kernel 6.6:
* To build scsi_transport_iscsi.ko, change CONFIG_SCSI_ISCSI_ATTRS
from =y to =m as this config is always tristate since 2.6.
Signed-off-by: Weijie Gao <hackpascal@gmail.com>
package/kernel/linux/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/block.mk
b/package/kernel/linux/modules/block.mk
index 5e6eefa76a94916ae8ef9c842bb361e6885eaa81..49a1b6fce1155f4d4172ccdf90bd48fdbca33920 100644
(file)
--- a/
package/kernel/linux/modules/block.mk
+++ b/
package/kernel/linux/modules/block.mk
@@
-263,7
+263,7
@@
define KernelPackage/iscsi-initiator
CONFIG_INET \
CONFIG_SCSI_LOWLEVEL=y \
CONFIG_ISCSI_TCP \
- CONFIG_SCSI_ISCSI_ATTRS
=y
+ CONFIG_SCSI_ISCSI_ATTRS
FILES:= \
$(LINUX_DIR)/drivers/scsi/iscsi_tcp.ko \
$(LINUX_DIR)/drivers/scsi/libiscsi.ko \