projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e2c19b5
)
add a variable LIBRPC to refer to the external librpc if used
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 13 Feb 2011 01:45:07 +0000
(
01:45
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 13 Feb 2011 01:45:07 +0000
(
01:45
+0000)
SVN-Revision: 25497
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 1a9bfc859abbb2c6eff6b77d4395b8c10b7af37c..b69769aa407ecb92fcc0898a13bc5b424d7dac4d 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-117,6
+117,9
@@
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
LIBGCC_S=$(if $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so),-L$(TOOLCHAIN_DIR)/lib -lgcc_s,$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.a))
+ifdef CONFIG_USE_UCLIBC
+LIBRPC=-lrpc
+endif
ifndef DUMP
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)