projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
62b5f48
)
avoid includes that aren't required for current target (make download)
author
Mike Baker
<mbm@openwrt.org>
Wed, 21 Jun 2006 23:27:47 +0000
(23:27 +0000)
committer
Mike Baker
<mbm@openwrt.org>
Wed, 21 Jun 2006 23:27:47 +0000
(23:27 +0000)
SVN-Revision: 4045
openwrt/package/iptables/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/package/iptables/Makefile
b/openwrt/package/iptables/Makefile
index f1a7de1f4b0532d5cda19b7283d39aaed0a41e6a..35bba6dacb2ba7d90ddd94c0b9e4964b3f709e88 100644
(file)
--- a/
openwrt/package/iptables/Makefile
+++ b/
openwrt/package/iptables/Makefile
@@
-21,10
+21,6
@@
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MENU:=IPv4 / IPv6 firewall administration
include $(INCLUDE_DIR)/package.mk
-ifeq ($(DUMP),)
-include $(LINUX_DIR)/.config
-include $(INCLUDE_DIR)/netfilter.mk
-endif
define Package/iptables
SECTION:=net
@@
-213,6
+209,9
@@
define Package/ip6tables/install
endef
define BuildPlugin
+include $(LINUX_DIR)/.config
+include $(INCLUDE_DIR)/netfilter.mk
+
define Package/$(1)/install
install -m0755 -d $$(1)/usr/lib/iptables
for m in $$(patsubst xt_%,ipt_%,$(2)); do \