projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bc5b6ef
)
linux: don't break kmod-fs-nfs for Kernels < 3.6.x
author
Jo-Philipp Wich
<jow@openwrt.org>
Tue, 4 Feb 2014 15:55:03 +0000
(15:55 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Tue, 4 Feb 2014 15:55:03 +0000
(15:55 +0000)
SVN-Revision: 39462
package/kernel/linux/modules/fs.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/fs.mk
b/package/kernel/linux/modules/fs.mk
index 60933f21923139b2563d09d02362cd363882a5e4..867117fab0bd10058469c23b8ccd1bb75d5d4938 100644
(file)
--- a/
package/kernel/linux/modules/fs.mk
+++ b/
package/kernel/linux/modules/fs.mk
@@
-225,9
+225,14
@@
define KernelPackage/fs-nfs
CONFIG_NFS_FS \
CONFIG_NFS_USE_LEGACY_DNS=n \
CONFIG_NFS_USE_NEW_IDMAPPER=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
FILES:= \
$(LINUX_DIR)/fs/nfs/nfs.ko \
$(LINUX_DIR)/fs/nfs/nfsv3.ko
+else
+ FILES:= \
+ $(LINUX_DIR)/fs/nfs/nfs.ko
+endif
AUTOLOAD:=$(call AutoLoad,40,nfs nfsv3)
endef