kernel: adjust kmod-phy-aquantia dependencies for v6.12 kernel
authorMantas Pucka <mantas@8devices.com>
Fri, 22 Nov 2024 08:07:43 +0000 (10:07 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 17 Dec 2024 22:28:11 +0000 (23:28 +0100)
Driver moved to different CRC library in v6.12

Signed-off-by: Mantas Pucka <mantas@8devices.com>
package/kernel/linux/modules/netdevices.mk

index 6db6ad90c4aaa594a395e013f40ac1f5a8389b7b..50382c5f1564aa4954afc96dfc74472e913d0bc4 100644 (file)
@@ -512,7 +512,7 @@ $(eval $(call KernelPackage,phy-airoha-en8811h))
 define KernelPackage/phy-aquantia
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Aquantia Ethernet PHYs
-  DEPENDS:=+kmod-libphy +kmod-hwmon-core +kmod-lib-crc-ccitt
+  DEPENDS:=+kmod-libphy +kmod-hwmon-core +!LINUX_6_12:kmod-lib-crc-ccitt +LINUX_6_12:kmod-lib-crc-itu-t
   KCONFIG:=CONFIG_AQUANTIA_PHY
   FILES:=$(LINUX_DIR)/drivers/net/phy/aquantia/aquantia.ko
   AUTOLOAD:=$(call AutoLoad,18,aquantia,1)