uboot-envtools: add fw_loadenv tool
authorJohn Crispin <john@phrozen.org>
Tue, 17 Sep 2024 12:36:13 +0000 (14:36 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 2 Oct 2024 13:41:33 +0000 (15:41 +0200)
This tool will load the uboot environment to /var/run/uboot-env/. This allows
more efficient use when accessing multiple variables.

Signed-off-by: John Crispin <john@phrozen.org>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/fw_loadenv [new file with mode: 0644]

index 19c3073c74a9361bead389ceb0a28e61dd3f500c..875afad554cf3176543470631d25835c57e3efe7 100644 (file)
@@ -71,6 +71,7 @@ define Package/uboot-envtools/install
        $(LN) fw_printenv $(1)/usr/sbin/fw_setenv
        $(INSTALL_BIN) ./files/fw_printsys $(1)/usr/sbin
        $(INSTALL_BIN) ./files/fw_setsys $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/fw_loadenv $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/lib
        $(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
        $(INSTALL_DIR) $(1)/etc/uci-defaults
diff --git a/package/boot/uboot-envtools/files/fw_loadenv b/package/boot/uboot-envtools/files/fw_loadenv
new file mode 100644 (file)
index 0000000..9fe302c
--- /dev/null
@@ -0,0 +1,26 @@
+#!/usr/bin/ucode
+
+'use strict';
+
+const path = '/var/run/uboot-env/';
+
+import * as fs from 'fs';
+
+if (fs.lsdir(path)) {
+       warn(`env has already been loaded to ${path}\n`);
+       exit(0);
+}
+
+let fp = fs.popen('fw_printenv');
+let raw = fp.read('all');
+fp.close();
+
+if (!length(raw))
+       exit(0);
+
+fs.mkdir(path);
+for (let line in split(raw, '\n')) {
+       let vals = split(line, '=');
+       if (vals[0] && vals[1])
+               fs.writefile(path + vals[0], vals[1]);
+}