projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
994db96
)
don't try to create kmod packages that contain no files
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 25 Jul 2006 14:44:54 +0000
(14:44 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 25 Jul 2006 14:44:54 +0000
(14:44 +0000)
SVN-Revision: 4278
openwrt/package/kernel/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/package/kernel/Makefile
b/openwrt/package/kernel/Makefile
index c977501e089f511ea7be56e149b83d6b647b7427..b1155f4286672e164f259d5c7a5599ad8c5f1611 100644
(file)
--- a/
openwrt/package/kernel/Makefile
+++ b/
openwrt/package/kernel/Makefile
@@
-72,12
+72,14
@@
define KernelPackage
endef
ifeq ($(findstring m,$(KCONFIG)),m)
+ ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
$(CP) $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
endef
endif
+ endif
$$(eval $$(call BuildPackage,kmod-$(1)))
endef