bpf-headers: fix llvm invocation
authorKonstantin Demin <rockdrilla@gmail.com>
Thu, 13 Jun 2024 17:56:06 +0000 (20:56 +0300)
committerRobert Marko <robimarko@gmail.com>
Fri, 13 Sep 2024 10:20:01 +0000 (12:20 +0200)
- specify CC target explicitly
- define KBUILD_SYM32=n to select "native" build format (if building with 64-bit arch)
- rewrap lines (for good)

Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15702
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/bpf-headers/Makefile

index 5efd2e1cf0fb7453f38829441c9f6407cb678286..e75da738e6862ee7c95654c6389f6e829025a264 100644 (file)
@@ -53,7 +53,9 @@ KERNEL_MAKE := \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARCH=$(BPF_KARCH) \
                CROSS_COMPILE=$(BPF_ARCH)-linux- \
-               LLVM=1 CC="$(CLANG)" LD="$(TARGET_CROSS)ld" \
+               LLVM=1 KBUILD_SYM32=n \
+               CC="$(CLANG) --target=$(BPF_TARGET)" \
+               LD="$(TARGET_CROSS)ld" \
                HOSTCC="$(HOSTCC)" \
                HOSTCXX="$(HOSTCXX)" \
                KBUILD_HOSTLDLIBS="-L$(STAGING_DIR_HOST)/lib" \