compat-drivers: fix admin-update.sh network
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Wed, 24 Oct 2012 15:07:25 +0000 (08:07 -0700)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Wed, 24 Oct 2012 15:07:25 +0000 (08:07 -0700)
Sujith reported that building after admin-update.sh network
we get a build error with drm. Fix this by creating an empy
drm Makefile.

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
scripts/admin-update.sh

index 9b850261adcf111ced1a64b3df0a1c331c3ad551..7d6830e2084afa003e8af97a97d98fd2eb441896 100755 (executable)
@@ -539,6 +539,8 @@ if [[ "$ENABLE_DRM" == "1" ]]; then
 
        # Finally get the DRM top-level makefile
        cp $GIT_TREE/drivers/gpu/drm/Makefile drivers/gpu/drm
+else
+       touch drivers/gpu/drm/Makefile
 fi
 
 # Staging drivers in their own directory