admin-update refresh the patches
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 23 Mar 2010 23:58:07 +0000 (16:58 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 23 Mar 2010 23:58:07 +0000 (16:58 -0700)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
patches/01-netdev.patch
patches/03-rfkill.patch
patches/08-rename-iwl4965-config.patch
patches/09-threaded-irq.patch
patches/11-dev-pm-ops.patch
patches/15-symbol-export-conflicts.patch
patches/16-bluetooth.patch
patches/17-netdev-queue.patch
patches/19-kfifo.patch

index f976013e70ae06de7aac17268acbe3929bc023fc..a23cc739aaace8bf5497b49b38645a7bf2bccd81 100644 (file)
@@ -338,7 +338,7 @@ without creating a headache on maintenance of the pathes.
  };
 +#endif
  
- /* Look into using netdev destructor to shutdown ieee80211? */
+ /* Look into using netdev destructor to shutdown libipw? */
  
 @@ -6126,7 +6128,16 @@ static struct net_device *ipw2100_alloc_
        priv->ieee->perfect_rssi = -20;
@@ -423,7 +423,7 @@ without creating a headache on maintenance of the pathes.
        net_dev->wireless_handlers = &ipw_wx_handler_def;
 --- a/drivers/net/wireless/ipw2x00/libipw_module.c
 +++ b/drivers/net/wireless/ipw2x00/libipw_module.c
-@@ -154,6 +154,10 @@ struct net_device *alloc_ieee80211(int s
+@@ -154,6 +154,10 @@ struct net_device *alloc_libipw(int size
                goto failed;
        }
        ieee = netdev_priv(dev);
index cb5fac30bdd3b57b1f594a355bedd98dc910c709..39ade6aed15a1744817d2a6cfc72023dfa8a0c1f 100644 (file)
@@ -54,7 +54,7 @@ This would do the policing from within mac80211.
  #include <linux/sched.h>
  
  #include "rfkill.h"
-@@ -229,7 +233,7 @@ static int rfkill_connect(struct input_h
+@@ -232,7 +236,7 @@ static int rfkill_connect(struct input_h
  
        handle->dev = dev;
        handle->handler = handler;
@@ -101,7 +101,7 @@ This would do the policing from within mac80211.
  static atomic_t rfkill_input_disabled = ATOMIC_INIT(0);
  
  /**
-@@ -779,7 +779,7 @@ static int rfkill_resume(struct device *
+@@ -818,7 +818,7 @@ static int rfkill_resume(struct device *
  }
  
  static struct class rfkill_class = {
@@ -110,7 +110,7 @@ This would do the policing from within mac80211.
        .dev_release    = rfkill_release,
        .dev_attrs      = rfkill_dev_attrs,
        .dev_uevent     = rfkill_dev_uevent,
-@@ -925,7 +925,7 @@ int __must_check rfkill_register(struct 
+@@ -964,7 +964,7 @@ int __must_check rfkill_register(struct 
        if (!rfkill->persistent || rfkill_epo_lock_active) {
                schedule_work(&rfkill->sync_work);
        } else {
@@ -119,7 +119,7 @@ This would do the policing from within mac80211.
                bool soft_blocked = !!(rfkill->state & RFKILL_BLOCK_SW);
  
                if (!atomic_read(&rfkill_input_disabled))
-@@ -1153,7 +1153,7 @@ static int rfkill_fop_release(struct ino
+@@ -1192,7 +1192,7 @@ static int rfkill_fop_release(struct ino
        list_for_each_entry_safe(ev, tmp, &data->events, list)
                kfree(ev);
  
@@ -128,7 +128,7 @@ This would do the policing from within mac80211.
        if (data->input_handler)
                if (atomic_dec_return(&rfkill_input_disabled) == 0)
                        printk(KERN_DEBUG "rfkill: input handler enabled\n");
-@@ -1164,7 +1164,7 @@ static int rfkill_fop_release(struct ino
+@@ -1203,7 +1203,7 @@ static int rfkill_fop_release(struct ino
        return 0;
  }
  
@@ -137,7 +137,7 @@ This would do the policing from within mac80211.
  static long rfkill_fop_ioctl(struct file *file, unsigned int cmd,
                             unsigned long arg)
  {
-@@ -1197,7 +1197,7 @@ static const struct file_operations rfki
+@@ -1236,7 +1236,7 @@ static const struct file_operations rfki
        .write          = rfkill_fop_write,
        .poll           = rfkill_fop_poll,
        .release        = rfkill_fop_release,
@@ -146,7 +146,7 @@ This would do the policing from within mac80211.
        .unlocked_ioctl = rfkill_fop_ioctl,
        .compat_ioctl   = rfkill_fop_ioctl,
  #endif
-@@ -1227,7 +1227,7 @@ static int __init rfkill_init(void)
+@@ -1266,7 +1266,7 @@ static int __init rfkill_init(void)
                goto out;
        }
  
@@ -155,7 +155,7 @@ This would do the policing from within mac80211.
        error = rfkill_handler_init();
        if (error) {
                misc_deregister(&rfkill_miscdev);
-@@ -1243,7 +1243,7 @@ subsys_initcall(rfkill_init);
+@@ -1282,7 +1282,7 @@ subsys_initcall(rfkill_init);
  
  static void __exit rfkill_exit(void)
  {
@@ -208,7 +208,7 @@ This would do the policing from within mac80211.
  #include <net/cfg80211.h>
 --- a/drivers/net/wireless/ath/ath9k/hw.c
 +++ b/drivers/net/wireless/ath/ath9k/hw.c
-@@ -3224,7 +3224,7 @@ int ath9k_hw_fill_cap_info(struct ath_hw
+@@ -3232,7 +3232,7 @@ int ath9k_hw_fill_cap_info(struct ath_hw
  
        pCap->hw_caps |= ATH9K_HW_CAP_ENHANCEDPM;
  
index 83b7c2a4800c2b1a9189e7b4f7c63c6e1fcee061..ab495a49b2c3d1ad1198a96c034842942dc11335 100644 (file)
@@ -7,7 +7,7 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
 +++ b/drivers/net/wireless/iwlwifi/Makefile
 @@ -11,7 +11,7 @@ CFLAGS_iwl-devtrace.o := -I$(src)
  obj-$(CONFIG_IWLAGN)  += iwlagn.o
- iwlagn-objs           := iwl-agn.o iwl-agn-rs.o iwl-agn-led.o
+ iwlagn-objs           := iwl-agn.o iwl-agn-rs.o iwl-agn-led.o iwl-agn-ict.o
  
 -iwlagn-$(CONFIG_IWL4965) += iwl-4965.o
 +iwlagn-$(CONFIG_COMPAT_IWL4965) += iwl-4965.o
@@ -16,7 +16,7 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
  iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
 --- a/drivers/net/wireless/iwlwifi/iwl-agn.c
 +++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
-@@ -3796,10 +3796,10 @@ static void __devexit iwl_pci_remove(str
+@@ -3689,10 +3689,10 @@ static void __devexit iwl_pci_remove(str
  
  /* Hardware specific file defines the PCI IDs table for that hardware module */
  static DEFINE_PCI_DEVICE_TABLE(iwl_hw_card_ids) = {
index 0f3670743c64ad9a9736d741e3d7dcf62794c873..7aa4e8e4d0cfda6cb23dcecb8f10f6f67a083861 100644 (file)
@@ -6,7 +6,7 @@ thread in process context as well.
 
 --- a/drivers/net/wireless/b43/main.c
 +++ b/drivers/net/wireless/b43/main.c
-@@ -3915,8 +3915,13 @@ redo:
+@@ -3916,8 +3916,13 @@ redo:
        if (dev->dev->bus->bustype == SSB_BUSTYPE_SDIO) {
                b43_sdio_free_irq(dev);
        } else {
@@ -20,7 +20,7 @@ thread in process context as well.
        }
        mutex_lock(&wl->mutex);
        dev = wl->current_dev;
-@@ -3956,9 +3961,17 @@ static int b43_wireless_core_start(struc
+@@ -3957,9 +3962,17 @@ static int b43_wireless_core_start(struc
                        goto out;
                }
        } else {
@@ -38,7 +38,7 @@ thread in process context as well.
                if (err) {
                        b43err(dev->wl, "Cannot request IRQ-%d\n", dev->dev->irq);
                        goto out;
-@@ -4663,6 +4676,10 @@ static int b43_setup_bands(struct b43_wl
+@@ -4664,6 +4677,10 @@ static int b43_setup_bands(struct b43_wl
  
  static void b43_wireless_core_detach(struct b43_wldev *dev)
  {
@@ -51,7 +51,7 @@ thread in process context as well.
        b43_release_firmware(dev);
 --- a/drivers/net/wireless/b43/b43.h
 +++ b/drivers/net/wireless/b43/b43.h
-@@ -754,6 +754,9 @@ struct b43_wldev {
+@@ -756,6 +756,9 @@ struct b43_wldev {
        unsigned int tx_count;
        unsigned int rx_count;
  #endif
index 7b3500a6ef29c456d83d13951009c252f78740a4..ffa192b1798cc2a82537af153062a7ef03428530 100644 (file)
@@ -41,7 +41,7 @@ calls on compat code with only slight modifications.
 +}
 +#endif
  
- SIMPLE_DEV_PM_OPS(ath5k_pm_ops, ath5k_pci_suspend, ath5k_pci_resume);
static SIMPLE_DEV_PM_OPS(ath5k_pm_ops, ath5k_pci_suspend, ath5k_pci_resume);
  #define ATH5K_PM_OPS  (&ath5k_pm_ops)
 @@ -209,7 +236,12 @@ static struct pci_driver ath5k_pci_drive
        .id_table       = ath5k_pci_id_table,
index 798a08928a50722d3ce4a0dcec9fd95e156d73ec..1efa059a23c4108499aecf7eaaaf98cdf8a5eb42 100644 (file)
@@ -3,7 +3,7 @@ To avoid conflicts with the other export we rename our.
 
 --- a/net/mac80211/rx.c
 +++ b/net/mac80211/rx.c
-@@ -2565,7 +2565,12 @@ void ieee80211_rx(struct ieee80211_hw *h
+@@ -2556,7 +2556,12 @@ void ieee80211_rx(struct ieee80211_hw *h
   drop:
        kfree_skb(skb);
  }
index c0353e9e90c788e2ffb3a50ffe4a456e1c07c4d4..b0ad82e6a1d8ddb99637176cdec2c195b3557e98 100644 (file)
@@ -111,7 +111,7 @@ here still, but for now we keep this here.
  #include <asm/system.h>
 --- a/net/bluetooth/hci_sock.c
 +++ b/net/bluetooth/hci_sock.c
-@@ -471,7 +471,11 @@ drop:
+@@ -473,7 +473,11 @@ drop:
        goto done;
  }
  
@@ -123,7 +123,7 @@ here still, but for now we keep this here.
  {
        struct hci_ufilter uf = { .opcode = 0 };
        struct sock *sk = sock->sk;
-@@ -626,8 +630,12 @@ static struct proto hci_sk_proto = {
+@@ -628,8 +632,12 @@ static struct proto hci_sk_proto = {
        .obj_size       = sizeof(struct hci_pinfo)
  };
  
@@ -138,7 +138,7 @@ here still, but for now we keep this here.
  
 --- a/net/bluetooth/hci_sysfs.c
 +++ b/net/bluetooth/hci_sysfs.c
-@@ -68,7 +68,11 @@ static struct attribute_group bt_link_gr
+@@ -72,7 +72,11 @@ static struct attribute_group bt_link_gr
        .attrs = bt_link_attrs,
  };
  
@@ -150,7 +150,7 @@ here still, but for now we keep this here.
        &bt_link_group,
        NULL
  };
-@@ -126,7 +130,11 @@ static void del_conn(struct work_struct 
+@@ -130,7 +134,11 @@ static void del_conn(struct work_struct 
                dev = device_find_child(&conn->dev, NULL, __match_tty);
                if (!dev)
                        break;
@@ -162,7 +162,7 @@ here still, but for now we keep this here.
                put_device(dev);
        }
  
-@@ -392,7 +400,11 @@ static struct attribute_group bt_host_gr
+@@ -388,7 +396,11 @@ static struct attribute_group bt_host_gr
        .attrs = bt_host_attrs,
  };
  
@@ -431,7 +431,7 @@ here still, but for now we keep this here.
  module_init(hidp_init);
 --- a/net/bluetooth/rfcomm/sock.c
 +++ b/net/bluetooth/rfcomm/sock.c
-@@ -323,8 +323,13 @@ static struct sock *rfcomm_sock_alloc(st
+@@ -325,8 +325,13 @@ static struct sock *rfcomm_sock_alloc(st
        return sk;
  }
  
@@ -445,7 +445,7 @@ here still, but for now we keep this here.
  {
        struct sock *sk;
  
-@@ -704,7 +709,11 @@ static int rfcomm_sock_recvmsg(struct ki
+@@ -706,7 +711,11 @@ static int rfcomm_sock_recvmsg(struct ki
                copied += chunk;
                size   -= chunk;
  
@@ -457,7 +457,7 @@ here still, but for now we keep this here.
  
                if (!(flags & MSG_PEEK)) {
                        atomic_sub(chunk, &sk->sk_rmem_alloc);
-@@ -767,7 +776,11 @@ static int rfcomm_sock_setsockopt_old(st
+@@ -769,7 +778,11 @@ static int rfcomm_sock_setsockopt_old(st
        return err;
  }
  
@@ -498,7 +498,7 @@ here still, but for now we keep this here.
                rfcomm_dlc_close(dev->dlc, 0);
 --- a/net/bluetooth/sco.c
 +++ b/net/bluetooth/sco.c
-@@ -430,8 +430,12 @@ static struct sock *sco_sock_alloc(struc
+@@ -432,8 +432,12 @@ static struct sock *sco_sock_alloc(struc
        return sk;
  }
  
@@ -511,7 +511,7 @@ here still, but for now we keep this here.
  {
        struct sock *sk;
  
-@@ -645,7 +649,11 @@ static int sco_sock_sendmsg(struct kiocb
+@@ -647,7 +651,11 @@ static int sco_sock_sendmsg(struct kiocb
        return err;
  }
  
@@ -570,7 +570,7 @@ here still, but for now we keep this here.
  
 --- a/net/bluetooth/l2cap.c
 +++ b/net/bluetooth/l2cap.c
-@@ -822,8 +822,12 @@ static struct sock *l2cap_sock_alloc(str
+@@ -824,8 +824,12 @@ static struct sock *l2cap_sock_alloc(str
        return sk;
  }
  
@@ -583,7 +583,7 @@ here still, but for now we keep this here.
  {
        struct sock *sk;
  
-@@ -835,7 +839,11 @@ static int l2cap_sock_create(struct net 
+@@ -837,7 +841,11 @@ static int l2cap_sock_create(struct net 
                        sock->type != SOCK_DGRAM && sock->type != SOCK_RAW)
                return -ESOCKTNOSUPPORT;
  
@@ -595,7 +595,7 @@ here still, but for now we keep this here.
                return -EPERM;
  
        sock->ops = &l2cap_sock_ops;
-@@ -1764,7 +1772,11 @@ static int l2cap_sock_setsockopt_old(str
+@@ -1766,7 +1774,11 @@ static int l2cap_sock_setsockopt_old(str
        return err;
  }
  
index 34224e5d57b5df481b7bf4c76a782859fcfa3a8b..86b9b51538c8379fb7421a4477f37a75fa2d2c32 100644 (file)
@@ -14,7 +14,7 @@ The patch that introduced this on mac80211 was:
 
 --- a/net/mac80211/iface.c
 +++ b/net/mac80211/iface.c
-@@ -954,6 +954,7 @@ void ieee80211_if_remove(struct ieee8021
+@@ -1066,6 +1066,7 @@ void ieee80211_if_remove(struct ieee8021
   * Remove all interfaces, may only be called at hardware unregistration
   * time because it doesn't do RCU-safe list removals.
   */
@@ -22,7 +22,7 @@ The patch that introduced this on mac80211 was:
  void ieee80211_remove_interfaces(struct ieee80211_local *local)
  {
        struct ieee80211_sub_if_data *sdata, *tmp;
-@@ -970,6 +971,22 @@ void ieee80211_remove_interfaces(struct 
+@@ -1082,6 +1083,22 @@ void ieee80211_remove_interfaces(struct 
        mutex_unlock(&local->iflist_mtx);
        unregister_netdevice_many(&unreg_list);
  }
index ea3821c86d18f92f05aef9225c1afe1bcbe6e15c..28f20ee0f0e96a2e023cfad4814629a78c2ec19b 100644 (file)
@@ -17,7 +17,7 @@ not be backported easily with defines in the compat module.
        struct task_struct *main_thread;
 --- a/drivers/net/wireless/libertas/main.c
 +++ b/drivers/net/wireless/libertas/main.c
-@@ -855,8 +855,14 @@ static int lbs_init_adapter(struct lbs_p
+@@ -859,8 +859,14 @@ static int lbs_init_adapter(struct lbs_p
        priv->resp_len[0] = priv->resp_len[1] = 0;
  
        /* Create the event FIFO */
@@ -32,7 +32,7 @@ not be backported easily with defines in the compat module.
                lbs_pr_err("Out of memory allocating event FIFO buffer\n");
                goto out;
        }
-@@ -872,7 +878,12 @@ static void lbs_free_adapter(struct lbs_
+@@ -876,7 +882,12 @@ static void lbs_free_adapter(struct lbs_
        lbs_deb_enter(LBS_DEB_MAIN);
  
        lbs_free_cmd_buffer(priv);