transocks: fix unpack and build directory (#9571)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 17 Jun 2011 10:33:51 +0000 (10:33 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 17 Jun 2011 10:33:51 +0000 (10:33 +0000)
SVN-Revision: 27200

net/transocks/Makefile

index bdcc1c9a1ff4cd7db2c79054b9b1e46cc3525bbf..6e2cf14d44f3ba10f7abcacad9ae43e020afbf32 100644 (file)
@@ -17,10 +17,10 @@ PKG_SOURCE_SUBDIR:=transocks
 PKG_SOURCE_VERSION:=-DNOW
 PKG_SOURCE_PROTO:=cvs
 
-PKG_BUILD_DIR:=transocks
-
 include $(INCLUDE_DIR)/package.mk
 
+PKG_UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xf -
+
 define Build/Compile
        $(TARGET_CC) \
                -I$(STAGING_DIR)/usr/include \