mt76: mt7996: select required kernel and hostap options
authorDaniel Golle <daniel@makrotopia.org>
Mon, 10 Jun 2024 22:39:36 +0000 (23:39 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 10 Jun 2024 23:10:21 +0000 (00:10 +0100)
Select DRIVER_11AX_SUPPORT and KERNEL_RELAY also for kmod-mt7996 to
prevent build failure if only this driver is selected during build and
end up with (most) required hostap features (IEEE 802.11be rates are not
yet supported).

Reported-by: Arınç ÜNAL <arinc.unal@arinc9.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mt76/Makefile

index 03c97de797734f5270d323552c9f85222cef51d5..c6cce9cf9c67490cb4a8c524320dac3c84cb607d 100644 (file)
@@ -318,7 +318,7 @@ endef
 define KernelPackage/mt7996e
   $(KernelPackage/mt76-default)
   TITLE:=MediaTek MT7996E wireless driver
-  DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac +kmod-hwmon-core
+  DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac +kmod-hwmon-core +@DRIVER_11AX_SUPPORT +@KERNEL_RELAY
   FILES:= $(PKG_BUILD_DIR)/mt7996/mt7996e.ko
   AUTOLOAD:=$(call AutoProbe,mt7996e)
 endef