selftests/bpf: Change llvm flag -mcpu=probe to -mcpu=v3
authorYonghong Song <yhs@fb.com>
Wed, 19 Feb 2020 00:42:36 +0000 (16:42 -0800)
committerAlexei Starovoitov <ast@kernel.org>
Wed, 19 Feb 2020 23:15:07 +0000 (15:15 -0800)
The latest llvm supports cpu version v3, which is cpu version v1
plus some additional 64bit jmp insns and 32bit jmp insn support.

In selftests/bpf Makefile, the llvm flag -mcpu=probe did runtime
probe into the host system. Depending on compilation environments,
it is possible that runtime probe may fail, e.g., due to
memlock issue. This will cause generated code with cpu version v1.
This may cause confusion as the same compiler and the same C code
generates different byte codes in different environment.

Let us change the llvm flag -mcpu=probe to -mcpu=v3 so the
generated code will be the same regardless of the compilation
environment.

Signed-off-by: Yonghong Song <yhs@fb.com>
Signed-off-by: Alexei Starovoitov <ast@kernel.org>
Acked-by: Andrii Nakryiko <andriin@fb.com>
Link: https://lore.kernel.org/bpf/20200219004236.2291125-1-yhs@fb.com
tools/testing/selftests/bpf/Makefile

index 257a1aaaa37d6723a0729e53772bf6e696bdacf2..2a583196fa51741a8088134956b8d397e8d4015e 100644 (file)
@@ -209,7 +209,7 @@ define CLANG_BPF_BUILD_RULE
        $(call msg,CLNG-LLC,$(TRUNNER_BINARY),$2)
        ($(CLANG) $3 -O2 -target bpf -emit-llvm                         \
                -c $1 -o - || echo "BPF obj compilation failed") |      \
-       $(LLC) -mattr=dwarfris -march=bpf -mcpu=probe $4 -filetype=obj -o $2
+       $(LLC) -mattr=dwarfris -march=bpf -mcpu=v3 $4 -filetype=obj -o $2
 endef
 # Similar to CLANG_BPF_BUILD_RULE, but with disabled alu32
 define CLANG_NOALU32_BPF_BUILD_RULE
@@ -223,7 +223,7 @@ define CLANG_NATIVE_BPF_BUILD_RULE
        $(call msg,CLNG-BPF,$(TRUNNER_BINARY),$2)
        ($(CLANG) $3 -O2 -emit-llvm                                     \
                -c $1 -o - || echo "BPF obj compilation failed") |      \
-       $(LLC) -march=bpf -mcpu=probe $4 -filetype=obj -o $2
+       $(LLC) -march=bpf -mcpu=v3 $4 -filetype=obj -o $2
 endef
 # Build BPF object using GCC
 define GCC_BPF_BUILD_RULE