projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9122474
)
sunxi: update image Makefile to reflect updated DTS structure in 6.6
author
Zoltan HERPAI
<wigyori@uid0.hu>
Wed, 17 Apr 2024 11:48:41 +0000
(13:48 +0200)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Thu, 25 Apr 2024 14:34:25 +0000
(16:34 +0200)
For the ARM arch on 6.6, DTS files are moved into their vendor directories,
mimicking arm64. Reflect this in the image Makefile.
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/sunxi/image/Makefile
b/target/linux/sunxi/image/Makefile
index cc1c1ba42de3fe63173dd2721700d8465b3e6ded..d462880e904e6579338a375ada910433ffe8b9bf 100644
(file)
--- a/
target/linux/sunxi/image/Makefile
+++ b/
target/linux/sunxi/image/Makefile
@@
-34,7
+34,11
@@
define Device/Default
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
+ifneq ($(LINUX_6_1),)
SUNXI_DTS_DIR :=
+else
+ SUNXI_DTS_DIR :=allwinner/
+endif
SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef