projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
86f3d57
)
Add package for gpio-pwm
author
Claudio Mignanti
<c.mignanti@gmail.com>
Mon, 12 Jul 2010 13:20:01 +0000
(13:20 +0000)
committer
Claudio Mignanti
<c.mignanti@gmail.com>
Mon, 12 Jul 2010 13:20:01 +0000
(13:20 +0000)
SVN-Revision: 22143
package/kernel/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/other.mk
b/package/kernel/modules/other.mk
index 071645984bcfdd3e146b61f29f85aacfa958e35d..9b8259b3df70a145b62005d8a16b063d3ebe22c3 100644
(file)
--- a/
package/kernel/modules/other.mk
+++ b/
package/kernel/modules/other.mk
@@
-661,3
+661,19
@@
define KernelPackage/wdt-scx200/description
endef
$(eval $(call KernelPackage,wdt-scx200))
+
+
+define KernelPackage/pwm-gpio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PWM over GPIO
+ KCONFIG:=CONFIG_GENERIC_PWM \
+ CONFIG_GPIO_PWM
+ FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
+endef
+
+define KernelPackage/pwm-gpio/description
+ Kernel module to models a single-channel PWM device using a timer and a GPIO pin
+endef
+
+$(eval $(call KernelPackage,pwm-gpio))