---- net-snmp-5.1.2.orig/agent/mibgroup/mibII/interfaces.c
-+++ net-snmp-5.1.2/agent/mibgroup/mibII/interfaces.c
-@@ -1598,6 +1612,10 @@
+--- a/agent/mibgroup/mibII/interfaces.c
++++ b/agent/mibgroup/mibII/interfaces.c
+@@ -1550,6 +1550,10 @@ Interface_Scan_Init(void)
struct ifnet *nnew;
char *stats, *ifstart = line;
if (line[strlen(line) - 1] == '\n')
line[strlen(line) - 1] = '\0';
-@@ -1631,7 +1649,7 @@
+@@ -1583,7 +1587,7 @@ Interface_Scan_Init(void)
&coll) != 5)) {
if ((scan_line_to_use == scan_line_2_2)
&& !strstr(line, "No statistics available"))
---- net-snmp-5.1.2.orig/local/Makefile.in
-+++ net-snmp-5.1.2/local/Makefile.in
-@@ -58,7 +58,7 @@
+--- a/local/Makefile.in
++++ b/local/Makefile.in
+@@ -100,7 +100,7 @@ tkmib.made: $(srcdir)/tkmib
mib2c.made: $(srcdir)/mib2c
if test "x$(PERL)" != "x" ; then \
else \
touch mib2c.made; \
fi
---- net-snmp-5.1.2.orig/mibs/Makefile.in
-+++ net-snmp-5.1.2/mibs/Makefile.in
-@@ -43,11 +43,15 @@
+--- a/mibs/Makefile.in
++++ b/mibs/Makefile.in
+@@ -48,11 +48,15 @@ NETSNMPMIBS = NET-SNMP-TC.txt NET-SNMP-M
UCDMIBS = UCD-SNMP-MIB.txt UCD-DEMO-MIB.txt UCD-IPFWACC-MIB.txt \
UCD-DLMOD-MIB.txt UCD-DISKIO-MIB.txt
all: standardall
---- net-snmp-5.1.2.orig/Makefile.top
-+++ net-snmp-5.1.2/Makefile.top
-@@ -27,6 +27,7 @@
+--- a/Makefile.top
++++ b/Makefile.top
+@@ -26,6 +26,7 @@ man8dir = $(mandir)/man8
snmplibdir = $(datadir)/snmp
mibdir = $(snmplibdir)/mibs
persistentdir = @PERSISTENT_DIRECTORY@
+sysconfdir = @sysconfdir@
DESTDIR = @INSTALL_PREFIX@
- INSTALL_PREFIX = @INSTALL_PREFIX@
+ INSTALL_PREFIX = $(DESTDIR)
---- net-snmp-5.1.2.orig/local/mib2c
-+++ net-snmp-5.1.2/local/mib2c
-@@ -60,8 +60,9 @@
+--- a/local/mib2c
++++ b/local/mib2c
+@@ -60,8 +60,9 @@ $currentlevel = -1;
if($ENV{MIB2C_DIR}) {
push @def_search_dirs, split(/:/, $ENV{MIB2C_DIR});
}
-diff -ruN net-snmp-5.4.1.orig/mibs/BGP4-MIB.txt net-snmp-5.4.1/mibs/BGP4-MIB.txt
---- net-snmp-5.4.1.orig/mibs/BGP4-MIB.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/BGP4-MIB.txt 2007-09-20 16:30:52.000000000 +0200
+--- /dev/null
++++ b/mibs/BGP4-MIB.txt
@@ -0,0 +1,929 @@
+ BGP4-MIB DEFINITIONS ::= BEGIN
+
+ ::= { bgpMIBGroups 5 }
+
+ END
-diff -ruN net-snmp-5.4.1.orig/mibs/BRIDGE-MIB.txt net-snmp-5.4.1/mibs/BRIDGE-MIB.txt
---- net-snmp-5.4.1.orig/mibs/BRIDGE-MIB.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/BRIDGE-MIB.txt 2007-09-20 16:30:52.000000000 +0200
+--- /dev/null
++++ b/mibs/BRIDGE-MIB.txt
@@ -0,0 +1,1075 @@
+BRIDGE-MIB DEFINITIONS ::= BEGIN
+
+ ::= 2
+
+END
-diff -ruN net-snmp-5.4.1.orig/mibs/GNOME-SMI.txt net-snmp-5.4.1/mibs/GNOME-SMI.txt
---- net-snmp-5.4.1.orig/mibs/GNOME-SMI.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/GNOME-SMI.txt 2007-09-20 16:33:55.000000000 +0200
+--- /dev/null
++++ b/mibs/GNOME-SMI.txt
@@ -0,0 +1,88 @@
+GNOME-SMI DEFINITIONS ::= BEGIN
+
+-- more to come if necessary.
+
+END
-diff -ruN net-snmp-5.4.1.orig/mibs/OSPF-MIB.txt net-snmp-5.4.1/mibs/OSPF-MIB.txt
---- net-snmp-5.4.1.orig/mibs/OSPF-MIB.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/OSPF-MIB.txt 2007-09-20 16:30:52.000000000 +0200
+--- /dev/null
++++ b/mibs/OSPF-MIB.txt
@@ -0,0 +1,2723 @@
+OSPF-MIB DEFINITIONS ::= BEGIN
+
+ ::= { ospfGroups 13 }
+
+END
-diff -ruN net-snmp-5.4.1.orig/mibs/OSPF-TRAP-MIB.txt net-snmp-5.4.1/mibs/OSPF-TRAP-MIB.txt
---- net-snmp-5.4.1.orig/mibs/OSPF-TRAP-MIB.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/OSPF-TRAP-MIB.txt 2007-09-20 16:30:52.000000000 +0200
+--- /dev/null
++++ b/mibs/OSPF-TRAP-MIB.txt
@@ -0,0 +1,443 @@
+OSPF-TRAP-MIB DEFINITIONS ::= BEGIN
+
+
+
+END
-diff -ruN net-snmp-5.4.1.orig/mibs/RIPv2-MIB.txt net-snmp-5.4.1/mibs/RIPv2-MIB.txt
---- net-snmp-5.4.1.orig/mibs/RIPv2-MIB.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/RIPv2-MIB.txt 2007-09-20 16:30:52.000000000 +0200
+--- /dev/null
++++ b/mibs/RIPv2-MIB.txt
@@ -0,0 +1,530 @@
+ RIPv2-MIB DEFINITIONS ::= BEGIN
+
+ "This group defines peer information for RIP-II systems."
+ ::= { rip2Groups 4 }
+END
-diff -ruN net-snmp-5.4.1.orig/mibs/SOURCE-ROUTING-MIB.txt net-snmp-5.4.1/mibs/SOURCE-ROUTING-MIB.txt
---- net-snmp-5.4.1.orig/mibs/SOURCE-ROUTING-MIB.txt 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.4.1/mibs/SOURCE-ROUTING-MIB.txt 2007-09-20 16:30:52.000000000 +0200
+--- /dev/null
++++ b/mibs/SOURCE-ROUTING-MIB.txt
@@ -0,0 +1,452 @@
+SOURCE-ROUTING-MIB DEFINITIONS ::= BEGIN
+
---- net-snmp-5.4.orig/FAQ 2006-11-25 00:34:18.000000000 +0100
-+++ net-snmp-5.4/FAQ 2006-11-25 00:37:09.000000000 +0100
-@@ -98,7 +98,7 @@
+--- a/FAQ
++++ b/FAQ
+@@ -99,7 +99,7 @@ TABLE OF CONTENTS
I don't understand the new access control stuff - what does it mean?
How do I configure SNMPv3 users?
The 'createUser' line disappears when I start the agent. Why?
My new agent is ignoring the old snmpd.conf file. Why?
Why am I getting "Connection refused"?
Why can't I see values in the UCDavis 'extensible' or 'disk' trees?
-@@ -630,7 +630,7 @@
+@@ -643,7 +643,7 @@ How do I add a MIB to the tools?
There are two steps required to add a new MIB file to the tools.
Firstly, copy the MIB file into the appropiate location:
(which makes it available to everyone on the system)
or
-@@ -1158,7 +1158,7 @@
+@@ -1177,7 +1177,7 @@ My traphandler script doesn't work when
If this is the case, then you can specify this interpreter
explicitly as part of the trap handle directive:
In this case, it's almost certain that you'll also
need to give the full path to the traphandle script (as shown)
-@@ -1232,7 +1232,7 @@
+@@ -1251,7 +1251,7 @@ OK, what should I put in snmp.conf?
string to use.
Some of these (such as the MIB file location), might be best put in
/etc/snmp/snmp.conf) to apply to all users of the system. Others
(particularly the SNMPv3 security settings), are more likely to refer
to a particular user, and should go in a personal snmp.conf file
-@@ -1455,7 +1455,7 @@
+@@ -1476,7 +1476,7 @@ Why aren't my mib files being read in?
Alternatively, the tools may be looking in the wrong place.
Again, this is set when the suite is first configured and compiled.
This can be changed using the environmental variable 'MIBDIRS'
or the snmp.conf directive 'mibdirs'.
-@@ -2409,7 +2409,7 @@
+@@ -2430,7 +2430,7 @@ How do I configure SNMPv3 users?
There are three ways to configure SNMPv3 users:
containing the line
createUser {myUser} MD5 {myPassword} DES
-@@ -2422,7 +2422,7 @@
+@@ -2443,7 +2443,7 @@ How do I configure SNMPv3 users?
net-snmp-config --create-snmpv3-user
and follow the instructions. This will create an entry
Then re-start the snmpd agent.
3) Make sure the agent is running, and will respond to a suitable
-@@ -2455,16 +2455,16 @@
+@@ -2476,16 +2476,16 @@ The 'createUser' line disappears when I
-@@ -2477,7 +2477,7 @@
+@@ -2498,7 +2498,7 @@ My new agent is ignoring the old snmpd.c
distribution), with the current release installed from the source.
The default location for this file with the basic distribution is
---- net-snmp-5.1.2.orig/EXAMPLE.conf.def
-+++ net-snmp-5.1.2/EXAMPLE.conf.def
+--- a/EXAMPLE.conf.def
++++ b/EXAMPLE.conf.def
@@ -6,7 +6,7 @@
###############################################################################
#
access MyROGroup "" any noauth exact all none none
access MyRWGroup "" any noauth exact all all none
-@@ -100,8 +106,8 @@
+@@ -100,8 +106,8 @@ access MyRWGroup "" any noaut
# value of an object whose value is given here will fail with an error
# status of notWritable.
# Example output of snmpwalk:
# % snmpwalk -v 1 -c public localhost system
-@@ -135,13 +141,13 @@
+@@ -135,13 +141,13 @@ syscontact Me <me@somewhere.org>
#
# Make sure mountd is running
# A snmpwalk of the prTable would look something like this:
#
-@@ -199,7 +205,7 @@
+@@ -199,7 +205,7 @@ proc sendmail 10 1
# ARGS: optional arguments to be passed to the program
# a simple hello world
# Run a shell script containing:
#
-@@ -250,7 +256,7 @@
+@@ -250,7 +256,7 @@ exec echotest /bin/echo hello world
# Check the / partition and make sure it contains at least 10 megs.
# % snmpwalk -v 1 -c public localhost .EXTENSIBLEDOTMIB.DISKMIBNUM
# enterprises.ucdavis.diskTable.dskEntry.diskIndex.1 = 0
-@@ -279,7 +285,7 @@
+@@ -279,7 +285,7 @@ disk / 10000
# 15MAX: Similar, but for 15 min average.
# Check for loads:
# % snmpwalk -v 1 -c public localhost .EXTENSIBLEDOTMIB.LOADAVEMIBNUM
# enterprises.ucdavis.loadTable.laEntry.loadaveIndex.1 = 1
-@@ -365,7 +371,7 @@
+@@ -365,7 +371,7 @@ load 12 14 14
# (commented out here since it requires that you place the
# script in the right location. (its not installed by default))
# % snmpwalk -v 1 -c public localhost .EXTENSIBLEDOTMIB.255
# enterprises.ucdavis.255.1 = "life the universe and everything"
---- net-snmp-5.1.2.orig/EXAMPLE-trap.conf
-+++ net-snmp-5.1.2/EXAMPLE-trap.conf
+--- /dev/null
++++ b/EXAMPLE-trap.conf
@@ -0,0 +1,18 @@
+###############################################################################
+#
---- net-snmp-5.1.2-orig/agent/mibgroup/ieee802dot11.c 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.1.2-5/agent/mibgroup/ieee802dot11.c 2005-03-13 16:17:21.000000000 +0100
+--- /dev/null
++++ b/agent/mibgroup/ieee802dot11.c
@@ -0,0 +1,4915 @@
+/****************************************************************************
+* *
+ return ( changed );
+}
+
---- net-snmp-5.1.2-orig/agent/mibgroup/ieee802dot11.h 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.1.2-5/agent/mibgroup/ieee802dot11.h 2005-03-13 16:17:21.000000000 +0100
+--- /dev/null
++++ b/agent/mibgroup/ieee802dot11.h
@@ -0,0 +1,730 @@
+/****************************************************************************
+* *
+WriteMethod write_dot11DiversitySelectionRx;
+
+#endif /* _MIBGROUP_IEEE802DOT11_H */
---- net-snmp-5.1.2-orig/agent/mibgroup/iwlib.h 1970-01-01 01:00:00.000000000 +0100
-+++ net-snmp-5.1.2-5/agent/mibgroup/iwlib.h 2005-03-13 16:17:21.000000000 +0100
+--- /dev/null
++++ b/agent/mibgroup/iwlib.h
@@ -0,0 +1,502 @@
+/*
+ * Wireless Tools