projects
/
openwrt
/
staging
/
pepe2k.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bf059f7
)
prereq-build: limit python distutils check to <v3.12
author
Andre Heider
<a.heider@gmail.com>
Mon, 9 Jan 2023 15:38:05 +0000
(16:38 +0100)
committer
Robert Marko
<robimarko@gmail.com>
Wed, 16 Oct 2024 20:36:43 +0000
(22:36 +0200)
v3.12 won't have it anymore.
Signed-off-by: Andre Heider <a.heider@gmail.com>
Link:
https://github.com/openwrt/openwrt/pull/16699
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index 2378f5ad90c961472f8751f2d116f9978d976b7d..8b138cfc44e98a919d939c1f664e10d91cab38a9 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-201,7
+201,8
@@
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \
- $(STAGING_DIR_HOST)/bin/python3 -c 'from distutils import util'))
+ printf 'from sys import version_info\nif version_info < (3, 12):\n\tfrom distutils import util' | \
+ $(STAGING_DIR_HOST)/bin/python3 -))
$(eval $(call TestHostCommand,python3-stdlib, \
Please install the Python3 stdlib module, \