compat-2.6: Makefile: fixed test expressions for target install
authorJoerg Albert <jal2@gmx.de>
Wed, 5 Aug 2009 18:23:43 +0000 (11:23 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 5 Aug 2009 18:23:43 +0000 (11:23 -0700)
This removes the two errors of [ with target "install"

[: 9: missing ]
[: 9: missing ]

and works with sh as well.

Signed-off-by: Joerg Albert <jal2@gmx.de>
Makefile

index 41a3c97f0905a1bb70c19198f2eaea83bd5b37ea..ab97de0591a2c8edf28fd538362624b0877541d6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -78,7 +78,7 @@ install-scripts:
        @install scripts/athload        $(DESTDIR)/usr/sbin/
        @install scripts/b43load        $(DESTDIR)/usr/sbin/
        @install scripts/iwl-load       $(DESTDIR)/usr/sbin/
-       @if [ ! -z $(MADWIFI) && -z "$(DESTDIR)" ]; then \
+       @if [ ! -z "$(MADWIFI)" ] && [ -z "$(DESTDIR)" ]; then \
                echo ;\
                echo -n "Note: madwifi detected, we're going to disable it. "  ;\
                echo "If you would like to enable it later you can run:"  ;\
@@ -87,7 +87,7 @@ install-scripts:
                echo Running athenable ath5k...;\
                /usr/sbin/athenable ath5k ;\
        fi
-       @if [ ! -z $(OLD_IWL) && -z "$(DESTDIR)" ]; then \
+       @if [ ! -z "$(OLD_IWL)" ] && [ -z "$(DESTDIR)" ]; then \
                echo ;\
                echo -n "Note: iwl4965 detected, we're going to disable it. "  ;\
                echo "If you would like to enable it later you can run:"  ;\