build: escape whitespaces in VERSION_DIST for Netgear images
authorSven Roederer <S.Roederer@colvistec.de>
Thu, 11 May 2023 10:42:12 +0000 (12:42 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 27 May 2023 19:32:47 +0000 (21:32 +0200)
Prevents subshell commands from failing to parse options
when having defined a whitespace in the VERSION_DIST.
As the called resulting images unlikely will handle
whitespace correctly, we replace them by "-".

Signed-off-by: Sven Roederer <S.Roederer@colvistec.de>
(cherry picked from commit 4071398b13aeee873cb5a48b00b6c90074763d5f)

include/image-commands.mk

index 402e3d71edb8d99e8eafdf97d0d730c5c69bc365..604b419b683432d45b071acfbe539c0f7b9a8e01 100644 (file)
@@ -378,7 +378,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
+               -B $(NETGEAR_BOARD_ID) -v $(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
@@ -391,7 +391,7 @@ define Build/netgear-encrypted-factory
                --output-file $@ \
                --model $(NETGEAR_ENC_MODEL) \
                --region $(NETGEAR_ENC_REGION) \
-               --version V1.0.0.0.$(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
+               --version V1.0.0.0.$(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
                --encryption-block-size 0x20000 \
                --openssl-bin "$(STAGING_DIR_HOST)/bin/openssl" \
                --key 6865392d342b4d212964363d6d7e7765312c7132613364316e26322a5a5e2538 \