compat-wireless: reorder config includes
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Sun, 1 Apr 2012 03:31:35 +0000 (20:31 -0700)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Sun, 1 Apr 2012 03:40:15 +0000 (20:40 -0700)
We need to include first the kernel config as otherwise
we end up trying to compile drivers which were disabled
for older kernels. This fixes compilation on 2.6.28 where
carl9170 was being compiled although we had disabled it
on config.mk.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
Makefile

index 89fb26681c5efab719d00b1774603dbae9025cc2..4c66dc6138ba0a68be1088fd578f6fc7aecc0482 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,8 +12,8 @@ DESTDIR?=
 
 ifneq ($(KERNELRELEASE),)
 
-include $(COMPAT_CONFIG_CW)
 include $(COMPAT_CONFIG)
+include $(COMPAT_CONFIG_CW)
 
 NOSTDINC_FLAGS := -I$(M)/include/ \
        -include $(M)/include/linux/compat-2.6.h \