collectd: fix build failure on avr32
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Jul 2010 12:12:02 +0000 (12:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Jul 2010 12:12:02 +0000 (12:12 +0000)
SVN-Revision: 22232

utils/collectd/Makefile

index a7047e22beba1bb1c17790d1e4570516ece63f2e..763a60021342d40a7efa5f8abf1c467f0fa27ef4 100644 (file)
@@ -135,6 +135,10 @@ define Package/collectd/description
  and provides mechanismns to store the values in a variety of ways.
 endef
 
+ifneq ($(CONFIG_avr32),)
+  TARGET_CFLAGS += -fsigned-char
+endif
+
 # common configure args
 CONFIGURE_ARGS+= \
        --disable-debug \