drm/i915: add header search path to subdir Makefiles
authorJani Nikula <jani.nikula@intel.com>
Wed, 26 Jun 2019 14:36:18 +0000 (17:36 +0300)
committerJani Nikula <jani.nikula@intel.com>
Thu, 27 Jun 2019 07:25:48 +0000 (10:25 +0300)
With the subdirectories we lost the ability to build individual files on
the command line, for example:

$ make drivers/gpu/drm/i915/display/intel_display.o

This was due to the top level directory missing from header search
path. Add the header search paths to subdir Makefiles.

Note that none of the other options in the top level i915 Makefile are
taken into account when building individual files. Usually this is not a
concern.

Reported-by: Imre Deak <imre.deak@intel.com>
Reported-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Cc: Chris Wilson <chris@chris-wilson.co.uk>
Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Jani Nikula <jani.nikula@intel.com>
Link: https://patchwork.freedesktop.org/patch/msgid/20190626143618.21800-2-jani.nikula@intel.com
drivers/gpu/drm/i915/display/Makefile
drivers/gpu/drm/i915/gem/Makefile
drivers/gpu/drm/i915/gt/Makefile

index 1c75b5c9790c7ff56695f13f85ac79017afb5496..eec6961015a115decfd878c39390cd3dd8b1e1d1 100644 (file)
@@ -1,2 +1,5 @@
+# For building individual subdir files on the command line
+subdir-ccflags-y += -I$(srctree)/$(src)/..
+
 # Extra header tests
 include $(src)/Makefile.header-test
index 07e7b8b840eade78061347fcca0d668840234efc..eec6961015a115decfd878c39390cd3dd8b1e1d1 100644 (file)
@@ -1 +1,5 @@
-include $(src)/Makefile.header-test # Extra header tests
+# For building individual subdir files on the command line
+subdir-ccflags-y += -I$(srctree)/$(src)/..
+
+# Extra header tests
+include $(src)/Makefile.header-test
index 1c75b5c9790c7ff56695f13f85ac79017afb5496..eec6961015a115decfd878c39390cd3dd8b1e1d1 100644 (file)
@@ -1,2 +1,5 @@
+# For building individual subdir files on the command line
+subdir-ccflags-y += -I$(srctree)/$(src)/..
+
 # Extra header tests
 include $(src)/Makefile.header-test