projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1b3f2a7
)
x86-64: Add --no-undefined to vDSO build
author
Andy Lutomirski
<luto@mit.edu>
Wed, 13 Jul 2011 13:24:12 +0000
(09:24 -0400)
committer
H. Peter Anvin
<hpa@linux.intel.com>
Wed, 13 Jul 2011 18:23:09 +0000
(11:23 -0700)
This gives much nicer diagnostics when something goes wrong. It's
supported at least as far back as binutils 2.15.
Signed-off-by: Andy Lutomirski <luto@mit.edu>
Link:
http://lkml.kernel.org/r/de0b50920469ff6359c529526e7639fdd36fa83c.1310563276.git.luto@mit.edu
Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
arch/x86/vdso/Makefile
patch
|
blob
|
history
diff --git
a/arch/x86/vdso/Makefile
b/arch/x86/vdso/Makefile
index bef0bc9624006d1839dc3050ab8356d7852593f4..5d179502a52cce8ee6b9f8f5fe643a35e0bf472a 100644
(file)
--- a/
arch/x86/vdso/Makefile
+++ b/
arch/x86/vdso/Makefile
@@
-26,6
+26,7
@@
targets += vdso.so vdso.so.dbg vdso.lds $(vobjs-y)
export CPPFLAGS_vdso.lds += -P -C
VDSO_LDFLAGS_vdso.lds = -m64 -Wl,-soname=linux-vdso.so.1 \
+ -Wl,--no-undefined \
-Wl,-z,max-page-size=4096 -Wl,-z,common-page-size=4096
$(obj)/vdso.o: $(src)/vdso.S $(obj)/vdso.so