projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
92b9955
)
orion: fix image build on non-linux systems
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 21 Jul 2009 02:30:46 +0000
(
02:30
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 21 Jul 2009 02:30:46 +0000
(
02:30
+0000)
SVN-Revision: 16938
target/linux/orion/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/orion/image/Makefile
b/target/linux/orion/image/Makefile
index 66edc04331e96109f552f47ec5424b720b9920da..21d01a105ad54e82107e67e670aa5bbada3717df 100644
(file)
--- a/
target/linux/orion/image/Makefile
+++ b/
target/linux/orion/image/Makefile
@@
-57,7
+57,7
@@
define Image/Build/Freecom
$(CP) $(KDIR)/dt2-uImage $(TARGET_DIR)/boot/uImage
rm -rf $(TARGET_DIR)/{var,jffs,rom}
$(INSTALL_DIR) $(TARGET_DIR)/var
- $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --
owner=root --group=root
-C $(TARGET_DIR)/ .
+ $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --
numeric-owner --owner=0 --group=0
-C $(TARGET_DIR)/ .
$(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img $(3)
endef