projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
84df952
)
RISC-V: Build tishift only on 64-bit
author
Zong Li
<zongbox@gmail.com>
Tue, 2 Oct 2018 08:52:27 +0000
(16:52 +0800)
committer
Palmer Dabbelt
<palmer@sifive.com>
Tue, 23 Oct 2018 00:02:55 +0000
(17:02 -0700)
Only RV64 supports 128 integer size.
Signed-off-by: Zong Li <zong@andestech.com>
Reviewed-by: Christoph Hellwig <hch@lst.de>
Signed-off-by: Palmer Dabbelt <palmer@sifive.com>
arch/riscv/lib/Makefile
patch
|
blob
|
history
diff --git
a/arch/riscv/lib/Makefile
b/arch/riscv/lib/Makefile
index 445ec84f9a4796e90ca80d882300d24ff770b435..5739bd05d289e5034b5d9faee2baebb1be1251ed 100644
(file)
--- a/
arch/riscv/lib/Makefile
+++ b/
arch/riscv/lib/Makefile
@@
-2,6
+2,7
@@
lib-y += delay.o
lib-y += memcpy.o
lib-y += memset.o
lib-y += uaccess.o
-lib-y += tishift.o
+
+lib-(CONFIG_64BIT) += tishift.o
lib-$(CONFIG_32BIT) += udivdi3.o