[packages] make packages depending on uclibc++ depend on CXX_DEPENDS
authorFlorian Fainelli <florian@openwrt.org>
Tue, 30 Oct 2012 16:57:58 +0000 (16:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 30 Oct 2012 16:57:58 +0000 (16:57 +0000)
SVN-Revision: 34016

libs/mysql/Makefile
libs/opal/Makefile
net/rrs/Makefile
net/yate/Makefile
utils/smartmontools/Makefile

index 06c2bafa5c4de8fa330423d9c4cf7dee4d70330b..40ad304ec619c89c34febb5c16d7f3334cb8628d 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=mysql
 PKG_VERSION:=5.1.53
@@ -29,7 +30,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libmysqlclient/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+uclibcxx +zlib
+  DEPENDS:=$(CXX_DEPENDS) +zlib
   TITLE:=MySQL client library
   URL:=http://dev.mysql.com/
 endef
index 380a8b29760c833e09257bf85260ec23b0360869..19ca8c99e68cb7ed1289b831fa17685343da39d7 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=opal
 PKG_VERSION:=3.2.1
@@ -26,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libopal
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+ptlib +uclibcxx
+  DEPENDS:=+ptlib $(CXX_DEPENDS)
   TITLE:=Open Phone Abstraction Library
   URL:=http://www.opalvoip.org/
 endef
index e7d032c8c5aef059ccfc1854d738562093329f34..efd54f490574f2eb316f40af5616b9639245b28c 100644 (file)
@@ -1,11 +1,12 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=rrs
 PKG_VERSION:=1.70
@@ -20,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/rrs/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+uclibcxx
+  DEPENDS:=$(CXX_DEPENDS)
   TITLE:=A reverse (connecting) remote shell
   URL:=http://www.cycom.se/dl/rrs/
 endef
index 5c74f290d6540adac72b7b71db1944b4242e20b9..27f2c28dbae44641737b53ef53b792ab9935fcc5 100644 (file)
@@ -7,6 +7,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/uclibc++.mk
 
 RELEASEVER:=3.2.0
 
@@ -33,7 +34,7 @@ endef
 
 define Package/$(PKG_NAME)
   $(call Package/yate/Default)
-  DEPENDS:=+libpthread +uclibcxx
+  DEPENDS:=+libpthread $(CXX_DEPENDS)
   TITLE:=Yet Another Telphony Engine
   MENU:=1
 endef
index a69ab9334cc27037807234802c862bd388b3494c..1fd75d68c03b2a4f62c0bb284f796b71f59d08fc 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/smartmontools/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+uclibcxx
+  DEPENDS:=$(CXX_DEPENDS)
   TITLE:=S.M.A.R.T Monitoring
   URL:=http://smartmontools.sourceforge.net/
 endef