collectd: fix another build failure on avr32
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Jul 2010 13:33:09 +0000 (13:33 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Jul 2010 13:33:09 +0000 (13:33 +0000)
the ted plugin fails on avr32 with the following error:

cc1: warnings being treated as errors
ted.c: In function 'ted_read_value':
ted.c:153: warning: format '%zi' expects type 'signed size_t', but argument 3 has type 'ssize_t'

SVN-Revision: 22234

utils/collectd/Makefile

index 763a60021342d40a7efa5f8abf1c467f0fa27ef4..6119572b7776f64380f6685b75f006b9139381f3 100644 (file)
@@ -276,7 +276,7 @@ $(eval $(call BuildPlugin,syslog,syslog output,syslog,))
 $(eval $(call BuildPlugin,tail,tail input,tail,))
 $(eval $(call BuildPlugin,table,table-like structured file input,table,))
 $(eval $(call BuildPlugin,teamspeak2,TeamSpeak2 input,teamspeak2,))
-$(eval $(call BuildPlugin,ted,The Energy Detective input,ted,))
+$(eval $(call BuildPlugin,ted,The Energy Detective input,ted,@((!TARGET_avr32)||BROKEN))) # fails on avr32 because of warnings treated as errors
 $(eval $(call BuildPlugin,tcpconns,TCP connection tracking input,tcpconns,))
 $(eval $(call BuildPlugin,thermal,system temperatures input,thermal,))
 $(eval $(call BuildPlugin,unixsock,unix socket output,unixsock,))