backports: replace BACKPORT_PWD with BACKPORT_DIR
authorLuis R. Rodriguez <mcgrof@suse.com>
Mon, 27 Oct 2014 20:54:16 +0000 (13:54 -0700)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Fri, 14 Nov 2014 21:47:15 +0000 (13:47 -0800)
This will also be used for built-in kernel integration, by
using this we can share more code with the built-in kernel
approach.

Reviewed-by: Johannes Berg <johannes@sipsolutions.net>
Signed-off-by: Luis R. Rodriguez <mcgrof@suse.com>
backport/Makefile
backport/Makefile.build
backport/Makefile.real
backport/scripts/uninstall.sh

index ea3982b1c0587f43d839a029b788ea717bc6d0c3..fcf2f0159a4c96c24b6d12523fb8fe6d57c61b52 100644 (file)
@@ -6,7 +6,7 @@ ifeq ($(KERNELRELEASE),)
 
 MAKEFLAGS += --no-print-directory
 SHELL := /bin/bash
-BACKPORT_PWD := $(shell pwd)
+BACKPORT_DIR := $(shell pwd)
 
 KMODDIR ?= updates
 ifneq ($(origin KLIB), undefined)
@@ -20,7 +20,7 @@ KERNEL_CONFIG := $(KLIB_BUILD)/.config
 KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile
 CONFIG_MD5 := $(shell md5sum $(KERNEL_CONFIG) 2>/dev/null | sed 's/\s.*//')
 
-export KLIB KLIB_BUILD BACKPORT_PWD KMODDIR KMODPATH_ARG
+export KLIB KLIB_BUILD BACKPORT_DIR KMODDIR KMODPATH_ARG
 
 # disable built-in rules for this file
 .SUFFIXES:
@@ -159,5 +159,5 @@ help: defconfig-help
        @echo ""
        @echo "Execute "make" or "make all" to build all targets marked with [*]"
 else
-include $(BACKPORT_PWD)/Makefile.kernel
+include $(BACKPORT_DIR)/Makefile.kernel
 endif
index d2090415cd52d1f12da9f05257379e9f8d72d5b2..a848b37ed64bbbe05b0bc29651af4fd2f6e72ba3 100644 (file)
@@ -3,8 +3,8 @@ export
 
 .PHONY: modules
 modules:
-       @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_PWD) modules
+       @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_DIR) modules
 
 .PHONY: clean
 clean:
-       @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_PWD) clean
+       @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_DIR) clean
index f60d5ca211a5ef2e769e9f7e9d95a20b0cbded5c..a0f491626f80714e897a64d4ebc517c9fc100e4b 100644 (file)
@@ -89,7 +89,7 @@ modules: backport-include/backport/autoconf.h
 
 .PHONY: install
 install: modules
-       @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_PWD)                     \
+       @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_DIR)                     \
                INSTALL_MOD_DIR=$(KMODDIR) $(KMODPATH_ARG)              \
                modules_install
        @./scripts/blacklist.sh $(KLIB)/ $(KLIB)/$(KMODDIR)
index 1eb42b0ba7da58ae3a3e058d438eb45b13f78a4e..b46d3fe7b31ba5024ab2121d63adf2098baba166 100755 (executable)
@@ -10,8 +10,8 @@ else
        compr=""
 fi
 
-for driver in $(find ${BACKPORT_PWD} -type f -name *.ko); do
-       mod_name=${driver/${BACKPORT_PWD}/${KLIB}${KMODDIR}}${compr}
+for driver in $(find ${BACKPORT_DIR} -type f -name *.ko); do
+       mod_name=${driver/${BACKPORT_DIR}/${KLIB}${KMODDIR}}${compr}
        echo "  uninstall" $mod_name
        rm -f $mod_name
 done