projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
133d634
)
fix firmwarehotplug prereq check on sdcc
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 21 Jan 2007 01:12:37 +0000
(
01:12
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 21 Jan 2007 01:12:37 +0000
(
01:12
+0000)
SVN-Revision: 6151
utils/firmwarehotplug/Makefile
patch
|
blob
|
history
diff --git
a/utils/firmwarehotplug/Makefile
b/utils/firmwarehotplug/Makefile
index 8b10fb7a8741dfead1a29355109084033e1df744..cff3be1c1415b37267ed4daec6ea6c2fc6ca82ad 100644
(file)
--- a/
utils/firmwarehotplug/Makefile
+++ b/
utils/firmwarehotplug/Makefile
@@
-50,9
+50,14
@@
endef
$(eval $(call BuildPackage,firmwarehotplug))
define Require/working-sdcc
- echo 'int main() { return 0; }' >$(TMP_DIR)/a.c; \
- sdcc -o $(TMP_DIR)/a.out $(TMP_DIR)/a.c; \
- rm -f $(TMP_DIR)/a.*
+ echo 'int main() { return 0; }' >$(TMP_DIR)/a.c; \
+ sdcc -o $(TMP_DIR)/a.out $(TMP_DIR)/a.c && { \
+ rm -f $(TMP_DIR)/a.* \
+ } || { \
+ rm -f $(TMP_DIR)/a.*; \
+ false \
+ }
+
endef
$(eval $(call Require,working-sdcc, \