tools: add Yafut to enable creating Yaffs filesystem images
authorMichał Kępień <openwrt@kempniu.pl>
Mon, 13 May 2024 17:26:15 +0000 (19:26 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 5 Jun 2024 15:03:24 +0000 (17:03 +0200)
The Yafut tool has so far been used to update the kernel on devices with
NAND flash via MTD character devices.  Recent upstream updates extended
the tool with limited support for working with filesystem images stored
in regular files.  This enables Yafut to be used for preparing a Yaffs
filesystem image for a device with NOR flash on a build host and
subsequently flashing it to the target device without using Yafut
itself.

Add Yafut to tools/ so that it can be compiled and run on the host
building OpenWRT.

Signed-off-by: Michał Kępień <openwrt@kempniu.pl>
Link: https://github.com/openwrt/openwrt/pull/13453
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/yafut/Makefile [new file with mode: 0644]

diff --git a/tools/yafut/Makefile b/tools/yafut/Makefile
new file mode 100644 (file)
index 0000000..a7e36e5
--- /dev/null
@@ -0,0 +1,20 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yafut
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/kempniu/yafut.git
+PKG_MIRROR_HASH:=9cc6b4c485ce16d44b67ebf79e8bee1e07aecde112da739cf33e8714ac3842e7
+PKG_SOURCE_DATE:=2024-05-13
+PKG_SOURCE_VERSION:=2b45baaf1cced47af8f22dd3acbf1df2f04c7510
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_INSTALL:=1
+
+$(eval $(call HostBuild))