projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
adeae0e
)
mbedtls: add --function-sections and --data-sections to CFLAGS
author
Felix Fietkau
<nbd@nbd.name>
Tue, 21 Feb 2017 13:33:14 +0000
(14:33 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Tue, 21 Feb 2017 15:05:03 +0000
(16:05 +0100)
This allows binaries that links these libraries statically to be reduced
by using --gc-sections on link
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/libs/mbedtls/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/mbedtls/Makefile
b/package/libs/mbedtls/Makefile
index 12b97da243d3a29af18d8141187c8173476cbf3e..a7d698c4fc53ca511a9ef1d2f9c27e7bfeefca71 100644
(file)
--- a/
package/libs/mbedtls/Makefile
+++ b/
package/libs/mbedtls/Makefile
@@
-48,6
+48,8
@@
endef
PKG_INSTALL:=1
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
CMAKE_OPTIONS += \
-DCMAKE_BUILD_TYPE:String="Release" \
-DUSE_SHARED_MBEDTLS_LIBRARY:Bool=ON \