ar71xx: add support for TL-WR741ND v5
authorJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:14:35 +0000 (08:14 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:14:35 +0000 (08:14 +0000)
This device is identical to the TL-WR740N v5, it even uses the same HWID (which
wasn't the case for older TL-WR741ND revisions).

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Backport of r46238

SVN-Revision: 48833

target/linux/ar71xx/image/Makefile

index 1fe88d54434eb3a335dbd32557f246a36a1eba52..78d35e1c9a83fe4586f76e23efd937142dd1bdfa 100644 (file)
@@ -531,6 +531,14 @@ define Device/tl-wr741nd-v4
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr741nd-v5
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR741ND-v4
+    DEVICE_PROFILE := TLWR741
+    TPLINK_HWID := 0x07400005
+    CONSOLE := ttyATH0,115200
+endef
+
 define Device/tl-wr743nd-v2
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WR741ND-v4
@@ -538,7 +546,7 @@ define Device/tl-wr743nd-v2
     TPLINK_HWID := 0x07430002
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
 
 define Device/tl-wr841n-v8
     $(Device/tplink-4mlzma)