[packages] tinc: The tinc init script needs to know all valid options used in /etc...
authorSaverio Proto <zioproto@gmail.com>
Mon, 21 May 2012 16:45:40 +0000 (16:45 +0000)
committerSaverio Proto <zioproto@gmail.com>
Mon, 21 May 2012 16:45:40 +0000 (16:45 +0000)
Author: Moritz Warning <moritzwarning@web.de>
This patch updates that list to tinc 0.18 (current version).

SVN-Revision: 31837

net/tinc/Makefile
net/tinc/files/tinc.init

index 1b849e7b494a1c033b0d969c57d637bc498697aa..0ad649357da597bf9d39c2761e0d440146dee063 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
 PKG_VERSION:=1.0.18
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages 
index e93f0d97a379df1b4ab15d521e7687007b31fa89..55a86a1d70a8d3b91177181c725bc4839563c0ef 100644 (file)
@@ -98,11 +98,12 @@ prepare_host() {
 
        # append flags
        append_conf_bools "$s" "$TMP_TINC/$n/hosts/$s" \
-               ClampMSS IndirectData PMTUDiscovery
+               ClampMSS IndirectData PMTUDiscovery TCPOnly
 
        # append params
        append_conf_params "$s" "$TMP_TINC/$n/hosts/$s" \
-               Address Cipher Compression Digest MACLength PMTU Port Subnet
+               Address Cipher Compression Digest MACLength PMTU \
+               Port PublicKey PublicKeyFile Subnet
 }
 
 check_gen_own_key() {
@@ -139,17 +140,20 @@ prepare_net() {
 
        # append flags
        append_conf_bools "$s" "$TMP_TINC/$s/tinc.conf" \
-               DirectOnly Hostnames IffOneQueue PriorityInheritance \
-               StrictSubnets TunnelServer \
-               ClampMSS IndirectData PMTUDiscovery
+               DecrementTTL DirectOnly Hostnames IffOneQueue \
+               LocalDiscovery PriorityInheritance StrictSubnets TunnelServer \
+               ClampMSS IndirectData PMTUDiscovery TCPOnly
 
        # append params
        append_conf_params "$s" "$TMP_TINC/$s/tinc.conf" \
                AddressFamily BindToAddress ConnectTo BindToInterface \
-               Forwarding GraphDumpFile Interface KeyExpire MACExpire \
-               MaxTimeout Mode Name PingInterval PingTimeout PrivateKeyFile \
-               ProcessPriority ReplayWindow UDPRcvBuf UDPSndBuf \
-               Address Cipher Compression Digest MACLength PMTU Port Subnet
+               Broadcast Device DeviceType Forwarding \
+               GraphDumpFile Interface KeyExpire MACExpire \
+               MaxTimeout Mode Name PingInterval PingTimeout \
+               PrivateKey PrivateKeyFile ProcessPriority ReplayWindow \
+               UDPRcvBuf UDPSndBuf \
+               Address Cipher Compression Digest MACLength PMTU \
+               Port PublicKey PublicKeyFile Subnet
 
        check_gen_own_key "$s" && return 0
 }