---- a/gettext-runtime/Makefile.in 2009-05-19 17:10:59.798239310 +0200
-+++ b/gettext-runtime/Makefile.in 2009-05-19 17:12:40.225999245 +0200
-@@ -154,7 +154,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
+--- a/gettext-runtime/Makefile.in
++++ b/gettext-runtime/Makefile.in
+@@ -208,7 +208,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
ETAGS = etags
CTAGS = ctags
DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
-diff -pruN gettext-0.17.orig/gettext-runtime/intl/localename.c gettext-0.17/gettext-runtime/intl/localename.c
---- gettext-0.17.orig/gettext-runtime/intl/localename.c 2009-05-19 17:25:21.925748747 +0200
-+++ gettext-0.17/gettext-runtime/intl/localename.c 2009-05-19 17:26:12.773472555 +0200
-@@ -996,7 +996,7 @@ gl_locale_name_posix (int category, cons
+--- a/gettext-runtime/intl/localename.c
++++ b/gettext-runtime/intl/localename.c
+@@ -2780,7 +2780,7 @@ gl_locale_name_posix (int category, cons
{
/* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
On some systems this can be done by the 'setlocale' function itself. */
+#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL && (!defined __UCLIBC__ || defined __UCLIBC_HAS_LOCALE__)
return setlocale (category, NULL);
#else
- const char *retval;
+ /* On other systems we ignore what setlocale reports and instead look at the
-diff -pruN gettext-0.17.orig//gettext-tools/gnulib-lib/libxml/xmlversion.in.h gettext-0.17/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
---- gettext-0.17.orig//gettext-tools/gnulib-lib/libxml/xmlversion.in.h 2010-02-17 17:35:35.758950208 +0100
-+++ gettext-0.17/gettext-tools/gnulib-lib/libxml/xmlversion.in.h 2010-02-17 17:56:56.510418934 +0100
+--- a/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
++++ b/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
*
* Whether iconv support is available
#define LIBXML_ICONV_ENABLED
#endif
-diff -pruN gettext-0.17.orig//gnulib-local/lib/libxml/xmlversion.in.h gettext-0.17/gnulib-local/lib/libxml/xmlversion.in.h
---- gettext-0.17.orig//gnulib-local/lib/libxml/xmlversion.in.h 2010-02-17 17:35:34.787184901 +0100
-+++ gettext-0.17/gnulib-local/lib/libxml/xmlversion.in.h 2010-02-17 17:56:49.578484210 +0100
+--- a/gnulib-local/lib/libxml/xmlversion.in.h
++++ b/gnulib-local/lib/libxml/xmlversion.in.h
@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
*
* Whether iconv support is available
---- a/gettext-tools/gnulib-lib/spawn.h
-+++ b/gettext-tools/gnulib-lib/spawn.h
-@@ -32,8 +32,10 @@
+--- a/gettext-tools/gnulib-lib/spawn.in.h
++++ b/gettext-tools/gnulib-lib/spawn.in.h
+@@ -31,8 +31,10 @@
/* Get definitions of 'struct sched_param' and 'sigset_t'.
But avoid namespace pollution on glibc systems. */
# include <signal.h>
#endif
+@@ -88,7 +90,11 @@ typedef struct
+ pid_t _pgrp;
+ sigset_t _sd;
+ sigset_t _ss;
++#ifdef __UCLIBC__
++ struct __sched_param _sp;
++#else
+ struct sched_param _sp;
++#endif
+ int _policy;
+ int __pad[16];
+ } posix_spawnattr_t;