projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4eabb03
)
Only build compat_firmware_class if CONFIG_FW_LOADER was enabled
author
Luis R. Rodriguez
<lrodriguez@atheros.com>
Tue, 19 Jan 2010 23:57:10 +0000
(15:57 -0800)
committer
Luis R. Rodriguez
<lrodriguez@atheros.com>
Tue, 19 Jan 2010 23:57:10 +0000
(15:57 -0800)
This prevents bothering with building compat_firmware_class if your
kernel lacks CONFIG_FW_LOADER support.
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
Makefile
patch
|
blob
|
history
diff --git
a/Makefile
b/Makefile
index 484386949f2d36533d41b3661915aedd9b324b3d..be2fdc5e59f73ab804fefe2040ca2133841b0594 100644
(file)
--- a/
Makefile
+++ b/
Makefile
@@
-19,8
+19,10
@@
$(foreach ver,$(COMPAT_VERSIONS),$(eval export CONFIG_COMPAT_KERNEL_$(ver)=y))
endif
ifeq ($(CONFIG_COMPAT_KERNEL_33),y)
+ifneq ($(CONFIG_FW_LOADER),)
export CONFIG_COMPAT_FIRMWARE_CLASS=m
endif
+endif
obj-y += compat/