[packages] openswan: fix setup scripts (#8029)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Feb 2011 15:18:26 +0000 (15:18 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Feb 2011 15:18:26 +0000 (15:18 +0000)
SVN-Revision: 25609

net/openswan/Makefile
net/openswan/patches/110-scripts.patch

index 45beb33c62274e802a6cfab02a982e0f2ffe6dd9..c5f9875486d29a36af2bbab6c9439572e7529fe9 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openswan
 PKG_VERSION:=2.6.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openswan.org/download
index eafbd9926dacdf2283a2a7a5789d353fd2023a83..db91c158a97d5166640474d7e61b4cf5c6d72147 100644 (file)
@@ -5,32 +5,32 @@
  3 files changed, 7 insertions(+), 2 deletions(-)
 
 --- /dev/null
-+++ openswan-2.6.29/programs/loggerfix
++++ b/programs/loggerfix
 @@ -0,0 +1,5 @@
 +#!/bin/sh
 +# use filename instead of /dev/null to log, but dont log to flash or ram
 +# pref. log to nfs mount
 +echo "$*" >> /dev/null
 +exit 0
---- openswan-2.6.29.orig/programs/_plutorun/_plutorun.in
-+++ openswan-2.6.29/programs/_plutorun/_plutorun.in
+--- a/programs/_plutorun/_plutorun.in
++++ b/programs/_plutorun/_plutorun.in
 @@ -155,7 +155,7 @@ then
                        exit 1
                fi
        else
 -              if test ! -w "`dirname $stderrlog`"
-+              if test ! -w "`echo $stderrlog | sed -r 's/(^.*\/)(.*$)/\1/'`"
++              if test ! -w "${stderrlog%/*}"
                then
                        echo Cannot write to directory to create \"$stderrlog\".
                        exit 1
---- openswan-2.6.29.orig/programs/_realsetup/_realsetup.in
-+++ openswan-2.6.29/programs/_realsetup/_realsetup.in
+--- a/programs/_realsetup/_realsetup.in
++++ b/programs/_realsetup/_realsetup.in
 @@ -290,7 +290,7 @@ case "$1" in
  
        # misc pre-Pluto setup
  
 -      perform test -d $subsysdir "&&" touch $subsyslock
-+      rm test -d `echo $subsyslock | sed -r 's/(^.*\/)(.*$)/\1/'` "&&" touch $subsyslock "&&" rm -f $subsyslock
++      perfrom test -d "${subsyslock%/*}" "&&" touch $subsyslock "&&" rm -f $subsyslock
  
        manualconns