ar71xx: expand kernel size for ubnt targets
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 29 Oct 2018 14:48:10 +0000 (15:48 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:48:09 +0000 (17:48 +0100)
Kernel 4.14 is pretty large causing a build error as the partition is too small.
Expand the kernel partition a bit to make it fit.

* ubnt-uap-pro
* ubnt-unifi-outdoor-plus

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
(backported from 162e016fed96eeea410e305b7edaf7008cf6ab77)

target/linux/ar71xx/image/generic-ubnt.mk

index de80c2d6afb7dc37b31834476b8486f435b22cf1..42275bae1863b49f7ec58f0d7b5ea25e9d7b26fa 100644 (file)
@@ -265,9 +265,9 @@ TARGET_DEVICES += ubnt-ls-sr71
 
 define Device/ubnt-uap-pro
   DEVICE_TITLE := Ubiquiti UAP Pro
-  KERNEL_SIZE := 1792k
+  KERNEL_SIZE := 2048k
   IMAGE_SIZE := 15744k
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1792k(kernel),13952k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2048k(kernel),13696k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
   UBNT_TYPE := BZ
   UBNT_CHIP := ar934x
   BOARDNAME := UAP-PRO