kernel-build.mk: Fix multi-core build warning.
authorZxl hhyccc <zxlhhy@gmail.com>
Fri, 4 Oct 2024 14:31:25 +0000 (22:31 +0800)
committerRobert Marko <robimarko@gmail.com>
Sun, 6 Oct 2024 11:49:39 +0000 (13:49 +0200)
In the case of multi-core compilation, the warning prompts to add a "+" sign.
````
warning: jobserver unavailable: using -j1. Add `+' to parent make rule.
`````
Signed-off-by: Zxl hhyccc <zxlhhy@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16598
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/kernel-build.mk

index 48e00fa4c61b2e4f98495cfd74005308177a408d..404c318d4130a860e693613ec68627246b4df7a2 100644 (file)
@@ -154,7 +154,7 @@ define BuildKernel
   download: $(if $(LINUX_SITE),$(DL_DIR)/$(LINUX_SOURCE))
   prepare: $(STAMP_PREPARED)
   compile: $(LINUX_DIR)/.modules
-       $(MAKE) -C image compile TARGET_BUILD=
+       +$(MAKE) -C image compile TARGET_BUILD=
 
   dtb: $(STAMP_CONFIGURED)
        $(_SINGLE)$(KERNEL_MAKE) scripts_dtc