projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9cf5568
)
valgrind: fix build failure on uml
author
John Crispin
<john@openwrt.org>
Mon, 1 Sep 2014 13:21:44 +0000
(13:21 +0000)
committer
John Crispin
<john@openwrt.org>
Mon, 1 Sep 2014 13:21:44 +0000
(13:21 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
Backport of r42229
SVN-Revision: 42372
package/devel/valgrind/Makefile
patch
|
blob
|
history
diff --git
a/package/devel/valgrind/Makefile
b/package/devel/valgrind/Makefile
index a55fb40d804643862b7381982caf6d7d9d5e7670..0074ad49b0159548a02f9d616fa08b7c2f66004c 100644
(file)
--- a/
package/devel/valgrind/Makefile
+++ b/
package/devel/valgrind/Makefile
@@
-77,7
+77,7
@@
define Package/valgrind/description
to speed up and reduce memory use of your programs.
endef
-CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(
LINUX_KARCH
)))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(
patsubst um,$(ARCH),$(LINUX_KARCH)
)))
CONFIGURE_VARS += \
UNAME_R=$(LINUX_VERSION)