projects
/
openwrt
/
staging
/
jogo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
93ce643
)
creates a passwd's shadow file if busybox supports the feature, fixes #2887
author
John Crispin
<john@openwrt.org>
Wed, 30 Jul 2008 17:09:01 +0000
(17:09 +0000)
committer
John Crispin
<john@openwrt.org>
Wed, 30 Jul 2008 17:09:01 +0000
(17:09 +0000)
SVN-Revision: 12017
package/base-files/Makefile
patch
|
blob
|
history
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index f4ef55d110e9f49b7e626be4c24f5e77a77a60d6..231647e98bc07fe5ca33f8cabbb25eb1b9e11162 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-147,6
+147,7
@@
define Package/base-files$(TARGET)/install
$(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
fi \
)
+ $(if $(CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS),cp $(1)/etc/passwd $(1)/etc/shadow)
$(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/ipkg.conf
mkdir -p $(1)/dev