projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d6de313
)
cmake: support verbose build that shows compiler commands
author
Felix Fietkau
<nbd@nbd.name>
Thu, 12 Jan 2017 13:32:02 +0000
(14:32 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Fri, 13 Jan 2017 09:23:43 +0000
(10:23 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/cmake/Makefile
patch
|
blob
|
history
diff --git
a/tools/cmake/Makefile
b/tools/cmake/Makefile
index c56cd40fb5a92b5240cacd0138b89d51ff6f65c6..08e5a69ecfcf4b26b88f98b7715f8f0ac5706388 100644
(file)
--- a/
tools/cmake/Makefile
+++ b/
tools/cmake/Makefile
@@
-29,4
+29,8
@@
HOST_CONFIGURE_VARS :=
HOST_CONFIGURE_ARGS := \
--prefix=$(STAGING_DIR_HOST)
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ HOST_MAKE_FLAGS += VERBOSE=1
+endif
+
$(eval $(call HostBuild))