projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8a22f31
)
gcc: enable LTO support unconditionally
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 10 Nov 2015 21:10:45 +0000
(21:10 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 10 Nov 2015 21:10:45 +0000
(21:10 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47442
toolchain/gcc/final/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/gcc/final/Makefile
b/toolchain/gcc/final/Makefile
index 1212d145abd8bdf3a22fbf6a68d5d05dadeb81b4..3434d894a2b501ba9545c99d47066fc43a7b5480 100644
(file)
--- a/
toolchain/gcc/final/Makefile
+++ b/
toolchain/gcc/final/Makefile
@@
-8,13
+8,9
@@
GCC_CONFIGURE += \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
- --with-slibdir=$(TOOLCHAIN_DIR)/lib
-
-ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- GCC_CONFIGURE += \
+ --with-slibdir=$(TOOLCHAIN_DIR)/lib \
--enable-lto \
--with-libelf=$(TOPDIR)/staging_dir/host
-endif
ifdef CONFIG_USE_MUSL
GCC_MAKE += gcc_cv_libc_provides_ssp=yes