move php related packages in a 'PHP' submenu, cleanup
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 18:18:41 +0000 (18:18 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 18:18:41 +0000 (18:18 +0000)
SVN-Revision: 8996

lang/pear-db/Makefile
lang/pear-xmlrpc/Makefile
lang/php-pear/Makefile
lang/php4/Makefile
lang/php5/Makefile

index 3471a879701ad5190a3cc322ec50f35ebaf27872..9c8afb52959ec96eb1f4bb69924ce1120aeeb39f 100644 (file)
@@ -1,27 +1,32 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=pear-db
+PKG_NAME:=php-pear-db
 PKG_VERSION:=1.7.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=DB-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://download.pear.php.net/package
 PKG_MD5SUM:=a57302138757500706e075a4d3d87ef7
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/DB-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/pear-db
-  DEPENDS:=+php5 +php-pear
+define Package/php-pear-db
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=pear-db
-  DESCRIPTION:=\
-       pear-db
-  URL:=http://pear.php.net
+  TITLE:=PEAR DB module
+  URL:=http://pear.php.net/
+  DEPENDS:=php-pear
 endef
 
 define Build/Configure
@@ -30,10 +35,10 @@ endef
 define Build/Compile
 endef
 
-define Package/pear-db/install
+define Package/php-pear-db/install
        $(INSTALL_DIR) $(1)/usr/lib/php
-       $(CP) -a $(PKG_BUILD_DIR)/DB.php $(PKG_BUILD_DIR)/DB \
-               $(1)/usr/lib/php
+       $(CP)   $(PKG_BUILD_DIR)/DB.php $(PKG_BUILD_DIR)/DB \
+               $(1)/usr/lib/php/
 endef
 
-$(eval $(call BuildPackage,pear-db))
+$(eval $(call BuildPackage,php-pear-db))
index 2740cba856fe4b808b6ababef9ea0747d553664e..75b6c5975203bdc83615b79965196ecd96e37ecb 100644 (file)
@@ -1,27 +1,32 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=pear-xmlrpc
+PKG_NAME:=php-pear-xmlrpc
 PKG_VERSION:=1.5.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=XML_RPC-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://download.pear.php.net/package
 PKG_MD5SUM:=1b516162ad65971b5fd04a7c279627ec
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/XML_RPC-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/pear-xmlrpc
-  DEPENDS:=+php5 +php-pear
+define Package/php-pear-xmlrpc
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=pear-xmlrpc
-  DESCRIPTION:=\
-       PHP's PEAR XML_RPC Library
-  URL:=http://pear.php.net
+  TITLE:=PEAR XML-RPC module
+  URL:=http://pear.php.net/
+  DEPENDS:=php-pear
 endef
 
 define Build/Configure
@@ -30,14 +35,12 @@ endef
 define Build/Compile
 endef
 
-
-define Package/pear-xmlrpc/install
+define Package/php-pear-xmlrpc/install
        $(INSTALL_DIR) $(1)/usr/lib/php/XML
-       $(CP) -a \
-               $(PKG_BUILD_DIR)/Dump.php \
+       $(CP)   $(PKG_BUILD_DIR)/Dump.php \
                $(PKG_BUILD_DIR)/RPC.php \
                $(PKG_BUILD_DIR)/Server.php \
-               $(1)/usr/lib/php/XML
+               $(1)/usr/lib/php/XML/
 endef
 
-$(eval $(call BuildPackage,pear-xmlrpc))
+$(eval $(call BuildPackage,php-pear-xmlrpc))
index 0c67833629ea0dff17095bffc5e0fb2e70a4d30e..ebf07fc045a169e8a0ac20e82ccadeb199b1a46e 100644 (file)
@@ -1,3 +1,11 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php-pear
@@ -7,21 +15,18 @@ PKG_RELEASE:=1
 PKG_SOURCE:=PEAR-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://download.pear.php.net/package
 PKG_MD5SUM:=06432c4768fdd7df2c4982c973d3f429
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/PEAR-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/php-pear
-  DEPENDS:=+php5
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=php-pear
-  DESCRIPTION:=\
-       php-pear
-  URL:=http://pear.php.net
+  TITLE:=PEAR
+  URL:=http://pear.php.net/
+  DEPENDS:=+php5
 endef
 
 define Build/Configure
@@ -32,8 +37,9 @@ endef
 
 define Package/php-pear/install
        $(INSTALL_DIR) $(1)/usr/lib/php
-       $(CP) -a $(PKG_BUILD_DIR)/PEAR.php $(PKG_BUILD_DIR)/PEAR \
-               $(1)/usr/lib/php
+       $(CP)   $(PKG_BUILD_DIR)/PEAR.php $(PKG_BUILD_DIR)/PEAR \
+               $(1)/usr/lib/php/
 endef
 
 $(eval $(call BuildPackage,php-pear))
+
index 047c13663755e9fcff7f69dfc1758f5e5e2e89c4..221bbb1927fc684bbee99677838747c43cb57b1d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,61 +15,64 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://fr.php.net/distributions/
 PKG_MD5SUM:=fbc67d240812136a9842bc1f2a217b7a
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/php4/Default
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PHP4 Hypertext preprocessor
-  DESCRIPTION:=\
-       PHP is a widely-used general-purpose scripting language that is especially \\\
-       suited for Web development and can be embedded into HTML.
   URL:=http://www.php.net/
 endef
 
+define Package/php4/Default/description
+ PHP is a widely-used general-purpose scripting language that is especially 
+ suited for Web development and can be embedded into HTML.
+endef
+
 define Package/php4
   $(call Package/php4/Default)
   DEPENDS:=+libopenssl +zlib
-  DESCRIPTION+=\\\
-       \\\
-       This package contains only the PHP config file. You must actually choose your \\\
-       PHP flavour (cli, cgi or fastcgi).
-  MENU:=1
 endef
 
-define Package/php4/conffiles
-/etc/php.ini
+define Package/php4/description
+$(call Package/php4/Default/description)
+ This package contains only the PHP config file. You must actually choose 
+ your PHP flavour (cli, cgi or fastcgi).
 endef
 
 define Package/php4-cli
   $(call Package/php4/Default)
   DEPENDS:=php4
   TITLE+= (CLI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CLI version of the PHP4 interpreter.
+endef
+
+define Package/php4-cli/description
+$(call Package/php4/Default/description)
+ This package contains the CLI version of the PHP4 interpreter.
 endef
 
 define Package/php4-cgi
   $(call Package/php4/Default)
   DEPENDS:=php4
   TITLE+= (CGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CGI version of the PHP4 interpreter.
+endef
+
+define Package/php4-cgi/description
+$(call Package/php4/Default/description)
+ This package contains the CGI version of the PHP4 interpreter.
 endef
 
 define Package/php4-fastcgi
   $(call Package/php4/Default)
   DEPENDS:=php4
   TITLE+= (FastCGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the FastCGI version of the PHP4 interpreter.
+endef
+
+define Package/php4-fastcgi/description
+$(call Package/php4/Default/description)
+ This package contains the FastCGI version of the PHP4 interpreter.
 endef
 
 define Package/php4-mod-curl
@@ -320,6 +323,10 @@ define Build/Compile
        $(call Build/Compile/php4-fastcgi)
 endef
 
+define Package/php4/conffiles
+/etc/php.ini
+endef
+
 define Package/php4/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/php.ini $(1)/etc/
@@ -370,3 +377,4 @@ $(eval $(call BuildPlugin,php4-mod-session,session))
 $(eval $(call BuildPlugin,php4-mod-sockets,sockets))
 $(eval $(call BuildPlugin,php4-mod-sqlite,sqlite))
 $(eval $(call BuildPlugin,php4-mod-xml,xml))
+
index eaee38dfe41f98a0b7eb04604e5ba1bd45123d60..839940e366501daf838eb47556be66d2c77f22d5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -19,54 +19,60 @@ PKG_MD5SUM:=55c97a671fdabf462cc7a82971a656d2
 include $(INCLUDE_DIR)/package.mk
 
 define Package/php5/Default
+  SUBMENU:=PHP
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PHP5 Hypertext preprocessor
-  DESCRIPTION:=\
-       PHP is a widely-used general-purpose scripting language that is especially \\\
-       suited for Web development and can be embedded into HTML.
   URL:=http://www.php.net/
 endef
 
+define Package/php5/Default/description
+ PHP is a widely-used general-purpose scripting language that is especially 
+ suited for Web development and can be embedded into HTML.
+endef
+
 define Package/php5
   $(call Package/php5/Default)
   DEPENDS:=+libopenssl +zlib
-  DESCRIPTION+=\\\
-       \\\
-       This package contains only the PHP config file. You must actually choose your \\\
-       PHP flavour (cli, cgi or fastcgi).
-  MENU:=1
 endef
 
-define Package/php5/conffiles
-/etc/php.ini
+define Package/php5/description
+$(call Package/php5/Default/description)
+ This package contains only the PHP config file. You must actually choose 
+ your PHP flavour (cli, cgi or fastcgi).
 endef
 
 define Package/php5-cli
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (CLI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CLI version of the PHP5 interpreter.
+endef
+
+define Package/php5-cli/description
+$(call Package/php5/Default/description)
+ This package contains the CLI version of the PHP5 interpreter.
 endef
 
 define Package/php5-cgi
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (CGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the CGI version of the PHP5 interpreter.
+endef
+
+define Package/php5-cgi/description
+$(call Package/php5/Default/description)
+ This package contains the CGI version of the PHP5 interpreter.
 endef
 
 define Package/php5-fastcgi
   $(call Package/php5/Default)
   DEPENDS:=php5
   TITLE+= (FastCGI)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the FastCGI version of the PHP5 interpreter.
+endef
+
+define Package/php5-fastcgi/description
+$(call Package/php5/Default/description)
+ This package contains the FastCGI version of the PHP5 interpreter.
 endef
 
 define Package/php5-mod-curl
@@ -338,6 +344,10 @@ define Build/Compile
        $(call Build/Compile/php5-fastcgi)
 endef
 
+define Package/php5/conffiles
+/etc/php.ini
+endef
+
 define Package/php5/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/php.ini $(1)/etc/