- Corkscrew - new package - Signed-off-by: koniu <gkusnierz@gmail.com>
authorScott V. Kamp <outbackdingo@gmail.com>
Fri, 3 Dec 2010 12:05:52 +0000 (12:05 +0000)
committerScott V. Kamp <outbackdingo@gmail.com>
Fri, 3 Dec 2010 12:05:52 +0000 (12:05 +0000)
SVN-Revision: 24227

net/corkscrew/Makefile [new file with mode: 0644]

diff --git a/net/corkscrew/Makefile b/net/corkscrew/Makefile
new file mode 100644 (file)
index 0000000..477ddec
--- /dev/null
@@ -0,0 +1,36 @@
+# 
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=corkscrew
+PKG_VERSION:=2.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.agroman.net/corkscrew/
+PKG_MD5SUM:=35df77e7f0e59c0ec4f80313be52c10a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/corkscrew
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Tunneling SSH through HTTP proxies.
+  URL:=http://www.agroman.net/corkscrew/
+endef
+
+define Build/Configure
+  $(call Build/Configure/Default,)
+endef
+
+define Package/corkscrew/install
+        $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/corkscrew $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,corkscrew))