projects
/
openwrt
/
staging
/
yousong.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
572ef85
)
build: prepare_rootfs: preserve prerm script
author
Yousong Zhou
<yszhou4tech@gmail.com>
Sun, 5 Mar 2017 07:01:07 +0000
(15:01 +0800)
committer
Yousong Zhou
<yszhou4tech@gmail.com>
Sun, 5 Mar 2017 09:23:46 +0000
(17:23 +0800)
They will still be needed at the time when pre-installed packages are to
be removed on target device
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
include/rootfs.mk
patch
|
blob
|
history
diff --git
a/include/rootfs.mk
b/include/rootfs.mk
index c014b1d14ab0963687417809431abc0bf314830c..dc400a05ed4215a3ca4eb889206c81037b9b56f1 100644
(file)
--- a/
include/rootfs.mk
+++ b/
include/rootfs.mk
@@
-82,7
+82,6
@@
define prepare_rootfs
@-find $(1) -name '.#*' | $(XARGS) rm -f
rm -f $(1)/usr/lib/opkg/lists/*
rm -f $(1)/usr/lib/opkg/info/*.postinst*
- rm -f $(1)/usr/lib/opkg/info/*.prerm*
$(call clean_ipkg,$(1))
$(call mklibs,$(1))
endef