gemini: Convert to use module for Realtek switch
authorLinus Walleij <linus.walleij@linaro.org>
Sun, 12 Jan 2025 00:08:17 +0000 (01:08 +0100)
committerLinus Walleij <linus.walleij@linaro.org>
Thu, 13 Feb 2025 23:34:16 +0000 (00:34 +0100)
Only the DIR-685 uses a Realtek DSA switch currently so
convert this platform to load it from a module and save
memory on all other devices.

At the same time drop the rt2800 PCI package that this
device actually isn't using, it needs an out-of-tree
wireless driver.

Link: https://patchwork.ozlabs.org/project/openwrt/patch/20250207-gemini-rtl-dsa-module-v3-1-e25a3df8bdc0@linaro.org/
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/gemini/config-6.6
target/linux/gemini/image/Makefile

index 2e590540afa95fdc52d5d17f4592b37cf45b7f93..c2e0cdd488ae0a4913a58b5f74297f96faf2252f 100644 (file)
@@ -287,13 +287,6 @@ CONFIG_NEED_KUSER_HELPERS=y
 CONFIG_NEED_PER_CPU_KM=y
 CONFIG_NEED_SRCU_NMI_SAFE=y
 CONFIG_NET_DEVLINK=y
-CONFIG_NET_DSA=y
-CONFIG_NET_DSA_REALTEK=y
-# CONFIG_NET_DSA_REALTEK_MDIO is not set
-# CONFIG_NET_DSA_REALTEK_RTL8365MB is not set
-CONFIG_NET_DSA_REALTEK_RTL8366RB=y
-CONFIG_NET_DSA_REALTEK_SMI=y
-CONFIG_NET_DSA_TAG_RTL4_A=y
 CONFIG_NET_EGRESS=y
 CONFIG_NET_INGRESS=y
 CONFIG_NET_NS=y
index a7988cf5fbefd7e2c11dd8d024053e80074ad9d2..389c8f8c442af8323de57c3f22b287716af88dfd 100644 (file)
@@ -158,7 +158,7 @@ define Device/dlink_dir-685
        DEVICE_MODEL := DIR-685 Xtreme N Storage Router
        DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
-                       kmod-rt2800-pci
+                       kmod-dsa-rtl8366rb
        IMAGES := factory.bin sysupgrade.bin
        # Pad to 128k erase blocks with 160 bytes WRGG header
        IMAGE/factory.bin := append-kernel | pad-offset 128k 160 | append-rootfs | dir685-pad-rootfs | dir685-image