adb: added patch for openssl 1.1.0 compatibility
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 25 May 2018 14:43:32 +0000 (11:43 -0300)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:47:42 +0000 (17:47 +0100)
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
(backported from f63f20fb93c7e67775cb01d97fc88b5b29452b81)
(rebased patches)
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/adb/Makefile
package/utils/adb/patches/001-create_Makefile.patch
package/utils/adb/patches/010-openssl-1.1.patch [new file with mode: 0644]

index c42c94d3a34e3a38c1d74cc0adfe6804d62f2aae..55f9c1a598622ef91cb650a40dd650a0d4583222 100644 (file)
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adb
 PKG_VERSION:=android.5.0.2_r1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://android.googlesource.com/platform/system/core
index be9f5f497aa730134b5045a03bfda7d8ae264902..d7fa00cb4c112a5f7df15c31167f278336b03d4a 100644 (file)
@@ -1,5 +1,5 @@
 --- /dev/null
-+++ b/adb/Makefile     2016-10-19 15:28:03.421194137 +0200
++++ b/adb/Makefile
 @@ -0,0 +1,42 @@
 +SRCS+= adb.c
 +SRCS+= adb_auth_host.c
diff --git a/package/utils/adb/patches/010-openssl-1.1.patch b/package/utils/adb/patches/010-openssl-1.1.patch
new file mode 100644 (file)
index 0000000..e4df372
--- /dev/null
@@ -0,0 +1,28 @@
+--- a/adb/adb_auth_host.c
++++ b/adb/adb_auth_host.c
+@@ -83,7 +83,13 @@ static int RSA_to_RSAPublicKey(RSA *rsa,
+     }
+     BN_set_bit(r32, 32);
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++    const BIGNUM *rsa_n, *rsa_e;
++    RSA_get0_key(rsa, &rsa_n, &rsa_e, NULL);
++    BN_copy(n, rsa_n);
++#else
+     BN_copy(n, rsa->n);
++#endif
+     BN_set_bit(r, RSANUMWORDS * 32);
+     BN_mod_sqr(rr, r, n, ctx);
+     BN_div(NULL, rem, n, r32, ctx);
+@@ -97,7 +103,11 @@ static int RSA_to_RSAPublicKey(RSA *rsa,
+         BN_div(n, rem, n, r32, ctx);
+         pkey->n[i] = BN_get_word(rem);
+     }
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++    pkey->exponent = BN_get_word(rsa_e);
++#else
+     pkey->exponent = BN_get_word(rsa->e);
++#endif
+ out:
+     BN_free(n0inv);