add the possibility of specifying and passing a path relative to $(PKG_BUILD_DIR...
authorMirko Vogt <mirko@openwrt.org>
Tue, 22 Feb 2011 12:13:07 +0000 (12:13 +0000)
committerMirko Vogt <mirko@openwrt.org>
Tue, 22 Feb 2011 12:13:07 +0000 (12:13 +0000)
SVN-Revision: 25660

Xorg/lib/qt4/files/qmake.mk

index f7f82e35d29563b0429a32680189ca8943983708..341500869fb32162cc0ffb1d511e86ddfdd167f1 100644 (file)
@@ -36,8 +36,8 @@ define Build/Configure/Qmake
        STAGING_DIR="$(STAGING_DIR)" \
        qmake \
                -spec $(QMAKE_SPECFILE) \
-               -o $(PKG_BUILD_DIR)/Makefile \
-               $(PKG_BUILD_DIR)/$(1).pro
+               -o $(PKG_BUILD_DIR)/$(2)/Makefile \
+               $(PKG_BUILD_DIR)/$(2)/$(1).pro
 endef
 
 # we need to pass everything to $(MAKE) as well, as Makefiles may invoke qmake once again for creating further Makefiles